Service Tier Administration Tool v3.4.0



  • lvanvugtlvanvugt Member Posts: 774
    edited 2017-12-05
    clienau wrote: »
    I will do it in a future version with more tests.

    Keep up the got spirit, Chris. And hey, love to be your tester anyway.
    Luc van Vugt,
    Never stop learning
    Van Vugt's dynamiXs
    Dutch Dynamics Community
  • AdministratorAdministrator Member, Moderator, Administrator Posts: 2,486
    Service Tier Administration Tool v3.1.2
    Version 3.1.2 (2017-11-27)

    NEW: Setting “Update Service State”. Enable or Disable background thread. F5 for manual.
    NEW: Setting “Update Service State Interval”. Interval in ms to trigger the background thread.
    NEW: Setting “Update Service List”. Enable or Disable check for new or removed services in background thread. (prohibit flash problems)
    REMOVED: Credential Manager ( Enabled in later version with more tests)

    Better performance on remote systems

    Discuss this download here.
  • denmark_serrano77denmark_serrano77 Member Posts: 12
    edited 2017-12-05
    Hi Chris,

    The Help Server settings on the RTC - Client User Settings section does not get saved properly. The Port number field value is somehow moved to the Help Server field.


  • dynavicsdynavics Member Posts: 5
    edited 2017-12-06
    it is still not possible to create a new service with version

    NST Version not exist in Build Update Path.

    All versions are registered in the RTC Version settings, the NST Version settings and the Classic Version Settings.
    Is there any reason why one must also keep a special folder for each "update" on top of the already existing?
    The Build updates from MS are always complete setup DVDs, not any build folders with NST or Client in it.
    PLease allow copying from the NST folder as in previous versions of STA.
    This is just not working
  • denmark_serrano77denmark_serrano77 Member Posts: 12
    @dynavics, i am able to create both a service and a service instance in 3.1.2. Can you confirm that both Navision Base Folder and Base Versions Folder are filled in under Settings?

  • saki82saki82 Member Posts: 3
    I hope someone can help me with the following issue:

    We have several NAV-Services running on a server, but users do not have admin rights on this machine.
    Therefore users cannot read/write/change these and trying to add the Remote Computer in STA fails with the message "No Access".

    So to implement these remote services into a local instance of STA, Is it enough to grant users full read/write access to these services on the Server, without having to give them admin rights?

    If not, what has to be done to achieve this, if possible at all?

    Thanks a lot!
  • phamhainguyen68phamhainguyen68 Member Posts: 2
    edited 2017-12-07

    I am currently having this issue with version 3.1.2. Any help is much appreciated:

    I usually use the NST Version Settings option to add new builds of NST and then use Create Service to create NST based on that. This works perfectly in version 2.5.5.

    However, in this version 3.1.2, I get this error message when trying to Create Service: Input string was not in a correct format.

    Does anyone know why it is happening like this?

    Thank you,
    Nguyen Pham.

  • clienauclienau Member Posts: 57
    edited 2017-12-08
    Hello thanks for the response.

    @denmark_serrano77: Thanks it is solve in next release. I have fix it.

    @phamhainguyen68 I look to your problems at the weekend.
    It could be a problem with the RTCSettings, NSTSettings and ClassSetting.

    @dynavics has simular problems. I use the new functionalities with Base Folder and Build Update Folder. I will do more test with the old functionalities at weekend.

    Thats a little bit tricky.

    The NST use a combination of WMI and ManagmentScope (Checks WIN32_services) and
    ServiceController (Get and refresh the service states).

    And another problem is the access to the file system.
    The NST check the different .exe files (finsql.exe, Microsoft.Dynamics.NAV.Server.exe ...) for FileVersionInfo to get the versions. And another thing is the read/write access to the config files.

    Thats the point that you need the admin rights at the moment.

  • phamhainguyen68phamhainguyen68 Member Posts: 2
    @clienau Thank you! I look forward to your next update. Have a nice weekend:).
  • greatscott001greatscott001 Member Posts: 32
    I don't want to add more to your work load but it would be nice to be able to start the NAV2018 classic client with the Command=generatesymbolreference, Database=<Dbname>, ServerName=<Sqlserver\SqlInstance> command line if need. Can this be added to the settings panel?
  • louagejlouagej Member Posts: 5
    edited 2017-12-12

    When I'm trying to add a service, the list of BASE folders alsways shows the same version.

    The Settings of 'Navision BASE Folder' and 'Base Versions Folder' or both set to 'C:\Program Files (x86)\Microsoft Dynamics NAV'

    Any idea what I can do to solve this?

    Kind regards,
  • NicouwNicouw Member Posts: 1

    we have the situation that after the update to 3.1.2. some services are not shown in the STA.
    especially with NAV version 2009
  • primeapprimeap Member Posts: 36

    Very useful Tool you have here, thank you!

    A missing feature on our site ist to be able to save wich CU it is alongside with the NST Version:


    What do you think?
  • navdeveloper02navdeveloper02 Member Posts: 2
    Feature request:

    Start Nav in configuration mode for profile entered in a dialog box.

    Much appreciated.
  • lvanvugtlvanvugt Member Posts: 774
    edited 2018-03-05
    Running into a major issue regarding the help server settings


    Filling the two fields will not result in any change in the CustomSettings.config (or maybe I am looking wrongly). And even worse: if I step into those fields and step out, move focus to another service tier and back the fields are set is per the screen shot.

    Is this intended behavior?
    Luc van Vugt,
    Never stop learning
    Van Vugt's dynamiXs
    Dutch Dynamics Community
  • kkirkebykkirkeby Member Posts: 1
    Thanks for a great tool!

    My colleagues and I have also encountered this problem in STA version 3.1.2.

    A colleague of mine runs STA version 2.5.5 and has no problems.
    louagej wrote: »

    When I'm trying to add a service, the list of BASE folders alsways shows the same version.

    The Settings of 'Navision BASE Folder' and 'Base Versions Folder' or both set to 'C:\Program Files (x86)\Microsoft Dynamics NAV'

    Any idea what I can do to solve this?

    Kind regards,

  • clienauclienau Member Posts: 57
    So i'm back. Sorry for a long time offline.

    I look too all errors and will solve the problems in the next days.
  • greatscott001greatscott001 Member Posts: 32
    Thanks for coming back to this. It is still an excellent tool.
  • greatscott001greatscott001 Member Posts: 32
    Thanks for the new update.

    First it appears that the "flashing" issue I had with Windows Server 2016 is resolved. Thank you.

    One problem is the the new Settings option "Generate Symbol Reference". This appears to be doing this command:
    finsql.exe Command=generatesymbolreference, Database="Demo Database NAV (11-0)", ServerName=.\NAVDEMO
    Which recreates the symbols for the database which is great but you don't need to do this every time.
    What I would have expected was this command:
    finsql.exe generatesymbolreference=yes
    Which continuously updates the symbols as you make changes (after the first generation of the symbols).
    See Running C/SIDE and AL Side-by-Side

    The problem with
    is that it takes a lot of time and can not be run on the same finsql.exe at the same time or you get errors like this in the Application Event Log:
    You cannot use the file C:\Program Files (x86)\Microsoft Dynamics NAV\110.21836.CU05\RoleTailored Client\naverrorlog.txt because it is already in use.
    As well, it never opens finsql, so it is not very useful.
  • greatscott001greatscott001 Member Posts: 32
    So I spoke too soon about the "flashing" issue in Windows Server 2016. It is fine on localhost but when I switch to a remote server the flashing is back.
  • clienauclienau Member Posts: 57
    Oh ok ;)

    But you can use the setting to create the symbols and disable the setting. I will create an own button in the next release.

    Best Regards.
  • clienauclienau Member Posts: 57
    I can not reproduce the problem. I have the STA installed on 4 Server with Windows Server 2016 with no problems.

    Can you check the Service List on the server. It could be a refresh problem with the count of services on that machine. You can disable the Refresh Timer. Check if that flashing problem is solved then.

    You can update manually with F5.

    Best Regards
  • greatscott001greatscott001 Member Posts: 32
    There are 25 NAV services on the remote server. If I uncheck the Update Service List the flash goes away. Not sure if it makes any difference but the servers involved are both Azure VMs in the same Azure domain.
  • greatscott001greatscott001 Member Posts: 32
    Even more strange, when I run STA locally on the server that was the remote one it flashes too. Would the MSINFO information help?
  • elToritoelTorito Member Posts: 191
    i would try the STA Tool. But i have some Install/config problems. When i start STA on local pc Versionsmanager says me i have Name 110 with Version 11.0.22292 and Name 60 with Version 6.0.34463

    In the Settings i have:
    Base Folder: C:\Program Files (x86)\Microsoft Dynamics NAV
    Base Versions Folder: C:\Program Files (x86)\Microsoft Dynamics NAV
    Build Update Folder: D:\MyUser\Documents\11.0.22292

    Then i try "Create New NAV Client Version", i can choose Base Version, but Build Version is blank, no option for select.

    The NAV 2009 Server and the 2018 NAV Server are on two different Servers. On my local maschine i only have the Clients installed, no server software. Must i install locally other things?

  • RatmaniacRatmaniac Member Posts: 1
    I've problem using Service Tier Administration Tool v3.2 with the latest version of NAV 2016 CU 37 (release on November 2018) on Windows Server 2012R2.
    I do the same operation I've always made for previous CUs but when I go to start service no way to run it.

    If I look into Event Viewer I found the following error:
    Event 7009, Service Control Manager:
    " A timeout was reached (30000 milliseconds) while waiting for the Microsoft Dynamics NAV Server <service name> service to connect. "

    Obviously if I use a other CU to create the service I've no problems.

    Is it possibile that newer NAV application software need some improvement in Service Tier Administration Tool?
  • vaprogvaprog Member Posts: 1,067
    edited 2018-12-05
    I know this error. Unfortunately I don't know how to solve it. The strange thing I noticed: even though the message claims a timeout after 30 seconds, the error is logged almost instantaneously.

    I thought to remember having fixed the error once by removing a blank space from a registry entry somewhere, but could not find anything later, when this happened again.

    I have never figured out how I am supposed to provide files for STA to install new versions from. So, my error might have been there.
  • MMattMMatt Member Posts: 14
    This tool is amazing, but there's one huge annoyance I wish would be resolved. When creating a service, the target folder text box is not editable, and the folder selection doesn't allow me to alter the address. It uses what I call the mouse click of death box.
    If that box had an actual address bar, it would be infinitely better.

  • clienauclienau Member Posts: 57
    So after a long time I will go back to the STA. I had a lot to do with product development and now I have some time to look at problems, bugs and improvements.
  • clienauclienau Member Posts: 57
    You have to choose the Basefolder which contains all build folders as "Build Update Folder".
    example: "D:\MyUser\Documents"

    Best Regards
Sign In or Register to comment.