NAV 2017 Phone client on Android type / edit problem

n.topalovn.topalov Posts: 26Member
Hello guys,
Here all the details about issue I found few days ago:

NAV Version:
NAV 2017

Where:
Android universal (phone) app, Chrome browser (Samsung Internet application is OK) using .WebClient\phone.aspx link; Android version is 7.0. I tested with almost 10 devices and only 3 of them was OK. iOS devices are OK as also Samsung Internet browser.

Description:
When try typing or selecting an option(basically try to edit anything) in edit mode in all pages the application is not showing the entered values. It is inserting the value but the text box just stay white (not able to see anything) and no cursor is displayed. You can not understand what you have entered until you save the record and open in view mode. You can see in the attachment that the text is there just it is not visible. It is like some font or content issue on the phone. I tried Reset All Settings, played a lot with chrome browser settings but it didn't help. I did not found any similar issues in the net, just one guy was left a feedback on the Dynamics NAV application in Google play a feedback mentioning that problem and suggesting a Factory Reset, but I didn't try Factory Reset since it will delete all data on the phone and obviously it is not a solution.

e5a100xtcnbw.png



The phone app was working for almost a year already without problems. I noticed that problem few days ago.


Thanks in advance!

Kind Regards,
Nikolay

Best Answers

Answers

  • ACaignieACaignie Posts: 48Member
    Hi Nikolay,
    The solution seems to be to delete the update of Google chrome (I had the same problem, see https://forum.mibuso.com/discussion/70712/nav-2017-phone-client-on-android-type-edit-problem#latest, solution thx to Stevekwok).
    Our partner reported it to Microsoft, as this is a temporary solution
  • n.topalovn.topalov Posts: 26Member
    Hi ACaignie,
    Thanks for the post. It helped me. What I did it is Disable and Enable Chrome on my phone. By that way it didn't install the new updates.
    We will looking forward for reliable solution from MS or Chrome ( really not sure which one need to fix something :) )

    Kind Regards,
    Nikolay
  • ufukufuk Posts: 512Member
    edited 2018-01-12
    In my case, these methods didn't worked. I replaced all the css files with the 2018 version and the problem is resolved. I haven't tested it in detail yet, but at the moment, everything looks correct.
    Ufuk Asci
    Pargesoft
  • n.topalovn.topalov Posts: 26Member
    Thank you JDVyska !

    I tested on separate environment and it worked!
Sign In or Register to comment.