Having trouble moving to AL with an unsual database

khaelykkhaelyk Member Posts: 2
So I'm doing work with a client that had previously decided they didn't want anything to do with extensions so someone before me literally removed everything from the Nav App table. Without some form of the base application existing in the database, Application symbols aren't generated no matter what I've tried and I'm not sure how to proceed. I was wondering if anyone else here had seen/dealt with anything similar? I'm relatively new to this NAV but have been doing software development for a long time; so, I apologize if I mess up any terminology or am missing any important information.

Version is BC14.0.43286.0

Answers

  • ShaiHuludShaiHulud Member Posts: 150
    You should start by downloading BC14 CU13 (link), extracting the "DVD" archive inside the archive, then publishing the System.app and Test.app from "\ModernDev\program files\Microsoft Dynamics NAV\140\AL Development Environment\". Then try to generate symbols, see if that helps
    Arturas Kulsinskas
    NaviLogic

    All opinions expressed are my own and are not reflective of my employer
  • khaelykkhaelyk Member Posts: 2
    Hey ShaiHulud, thank you so much for responding to my question. So, I have been able to publish the System and Test apps now; however, the trouble I'm having is with the Application symbols.

    • I have tried using the command line tool as described here: https://docs.microsoft.com/en-us/dynamics365/business-central/dev-itpro/developer/devenv-running-cside-and-al-side-by-side

    • I have made sure to check the "Enable loading application symbol references at server startup" setting on the BC server instance.

    •In VS Code, I have made sure all my settings are correct by using an original Microsoft database of the same version and making sure I could download the application symbols with that database.

    • I have tried using the Export-NavApplication command via powershell.

    • I have tried just blatantly copying all the data from the 'C:\ProgramData\Microsoft\Microsoft Dynamics NAV\140\Server\"instance"' MS version to the client version lol


    My current thought is, in one of the system tables in the database, there is (I'm fairly certain) a base application or something similar that is used to generate those symbols during server startup which got removed when the client ever-so-thoughtfully gutted their hope at using extensions and then changed their mind.

    I am currently in the process of migrating/merging the Microsoft version of the database with the client's to see if I can then go back and generate the symbols; however, I would like to know if you or anyone else has any more efficient/different ideas as to how to fix this issue.

    Thank you all for your time, I really do appreciate any help offered.
  • ShaiHuludShaiHulud Member Posts: 150
    How exactly does it fail generating symbols? Does it show anything in the Event Log or is there an error file in the installation folder? Could you post that error?
    Arturas Kulsinskas
    NaviLogic

    All opinions expressed are my own and are not reflective of my employer
Sign In or Register to comment.