The record in Item Ledger Entry already exists. Identification fields and Values: Entry No:......

SuhailSuhail Member Posts: 23
Hi, i faced same issue in Business Central "on premise" version, i delete ILE and VE and G/L Entry records using SQL query because it was wrong.

i know this the wrong procedure, when try to post the sales entries in open statements its gave the error in the pic.

i restart the NAV and SQL services but still the error occusr and when i check the the entry no. inside the table its not existing..

please how i can solve this issue becuase its stopped all posting linked to ILE and VE.

rvjnl805uav3.png

Answers

  • vaprogvaprog Member Posts: 1,012
    1. Resore your database to a date before you deleted entries.
    2. Never delete entries, especially not using SQL, unless you REALY know what you are doing and will not have to ask questions like this.

    Sorry to sound a little harsh, but entries are there to stay. And you need to test any changes in the system thoroughly before deploying, in order to make sure, you post the correct values. And you need to correct any errors by creating new entries which correct or cancel whathever had been posted incorrectly, regardless of whether the source of the error was the user or the system.
  • SuhailSuhail Member Posts: 23
    so there in no way to be fixed except restore the database ?
  • vaprogvaprog Member Posts: 1,012
    It is likely a programming error and not caused by deleting entries at all. So check recent code changes.

    The debugger is your friend here.

    And as you noticed, there are two entries inserted in the table with the same entry no. within the same transaction.
Sign In or Register to comment.