How to install CU01 over the Spring release? I keep on getting errors with the Repair and Install.

mgnmgn Posts: 37Member
Did anyone succeed in with installing CU01 over the Spring release version?

We have a development machine (windows10 1809) where we are working with NAV/BC versions 11 and 13. Over a month ago we installed the BC spring release (14). Then we wanted to apply CU01 https://support.microsoft.com/cs-cz/help/4501292/released-cumulative-updates-for-microsoft-dynamics-365-business

It seems that to use the CU01 update the BC old (Spring Release) installation has to be removed and the CU01 has to be installed. In older versions it was enough to replace the binaries with the ones of the CU dvd folder. A simple PS script did the trick. Now this does not work anymore.
I should have read the instructions better:
https://support.microsoft.com/en-us/help/4469914/how-to-install-a-microsoft-dynamics-365-business-central-cumulative
So, I uninstalled BC Spring release and tried to install CU01. And then I ran into several errors. In the end the result is not being able to install CU01.

Because I started off the wrong way (trying to replace the binaries), I did a new test on different machine. A VM with Windows10 Pro 1809 build 17763.437 with a similar NAV/BC installation. Same kind of errors and end result: not being able to successfully install CU01.

Below the complete scenario.
Uninstalled BC14 with the standard Windows 'Add or Remove Programs'. I see that some files are not deleted on the system, like config files. Fine.
Restarted the VM
I did a fresh installation by starting the Setup.exe from the dvd folder (which is annoying, because all the setup has to be entered again). The installation gave errors, saying that several components were already installed, like Server Administration Tool, Demo db and some Windows client files.
I ran Setup.exe again and used the Repair option. That gave the same error report.
I did an uninstall from the Setup.exe
Restarted the VM again, ran the Setup.exe again; Same errors.
Did a windows update to 1809 build 17763.592
Ran Setup.exe and choose Repair.

How to get out of this process and how to (simply) apply a CU01 ???





Answers

  • mgnmgn Posts: 37Member
    On a fresh Windows10 I did the following:
    - install the Spring release; full install, default setup
    - uninstall BC with windows 'Install or Remove Programs'
    - install CU01 Spring release

    Result: fatal errors and BC is not installed: no Server Configuration, Windows Client, C/Side dev environment. Very annoying.

    Did anyone succeed with this scenario?

    Do we have to wait for a fix or CU02 (and hope it is fixed)?
  • mgnmgn Posts: 37Member
    The long file and folder name structure caused the problem in combination with 7zip. :D
    I unzipped the file 'CU 01 Microsoft Dynamics 365 BC Spring 2019 Update On Premise NL.zip' in a new folder 'CU 01 Microsoft Dynamics 365 BC Spring 2019 Update On Premise NL' and then unzipped 'Dynamics.365.BC.32615.NL.DVD.zip' in a subfolder 'Dynamics.365.BC.32615.NL.DVD'.
    I used 7zip to do this, and this gave no errors: all files seemed to be unzipped without a problem.
    When doing the same with windows zip, an error occurred saying 'Path too long'. After unzipping in a new folder with a shorter folder-name structure, the installation worked fine.
    Strange enough, in windows explorer the folders and files extracted with windows zip and extracted with 7zip are exactly the same (I used Beyond Compare to compare).
    Would be nice if MS would use shorter file and folder names, though ;).
Sign In or Register to comment.