Microsoft Dynamics NAV 2009 SP1, Email attachment

When I send an email I want my purchase quote goes to the email body, currently it goes as html attachment. When I go to purchase order it works just fine.

I did compare these two objects and looked very similar, do you know where I should look?

I click Print then preview>>>file>>>send >>>Report by Email I see the quote in the email attachment but when I do this from the purchase order I can see the attachment in the email body.

Best Answers

  • sjensjen Posts: 53
    Accepted Answer
    Alright, I removed the logo and tested again and attachment went to email body instead of adding as and HTML. So the problem was the logo

Answers

  • sjensjen Member Posts: 53
    When I look at the documentation it says the default is adding the attachment as html. I checked the properties as well as the code but couldn't figure it out.
    Sending Reports by E-Mail
    Microsoft Dynamics NAV allows you to send reports by e-mail. These reports are sent in HTML format.
    This function is integrated with your e-mail system and allows you to send a report directly from Microsoft Dynamics
    NAV. For example, you can send relevant reports to other employees in your company.
    To Send a Report by E-Mail:
    1. Open the report or view the report with the Preview function.
    2. Click File, Send, Report by E-Mail and the program will automatically attach the report as a file in HTML
    format to an e-mail. The recipient can open the file with an Internet browser.
    
  • vijay_gvijay_g Member Posts: 883
    it may be different with different version. in nav 2009 r2 it is taking each report in body. btw, in any version it should work in one way in your case can you use standard report object of your report to check?
  • sjensjen Member Posts: 53
    Standard Purchase order goes to email body I see that without any problem but Purchase quote(50000 range) attachment is HTML. I don't know what I am missing. I compared those two objects and looks the same.
  • sjensjen Member Posts: 53
    I have a logo in my Purchase quote, does it make a difference? Maybe the logo is causing the problem? I see two attachments, one HTML file, and one logo.
  • sjensjen Member Posts: 53
    Accepted Answer
    Alright, I removed the logo and tested again and attachment went to email body instead of adding as and HTML. So the problem was the logo
Sign In or Register to comment.