Can´t find Database/Server with Connection Type = Default

surrendersurrender Member Posts: 5
edited 2014-06-26 in SQL General

I´m just desperated.
When i´m trying to open the database in de Classic Client (Connection Type = Default) the Database/Server cannot be found.
If i am changing Connection Type manually to "TCP/IP Sockets" everything is working fine in the Classic Client!

Now, the real problem is that when i´m opening the RTC client i can not choose which connection type to has to be used - Database opens automatically.
Later on, when i´m trying to print a document in the RTC i just get the message "Can not find Server xxxxx. Try again later or contact system administrator"

Now, I´ve tried to choose connection Type of RTC manually on the Server by accessing the path
"C:\Program Files (x86)\Microsoft Dynamics NAV\60\Service\CustomSettings" and then change "Net type" value to SOCKETS => it is still not working?!

Now I just don´t know why it is working on every other workstation - just on one single WS it´s not working.

I use Microsoft Dynamics NAV 2009 R2
SQL Server: 2012
The workstation works on a WIN7 64 bit system

Another point is that when i am enabling NamedPipes connections on the SQL Management console, the WS is connection by default.
Problem: All the other WS do not work any more.

Has anybody an idea what could be the reason??

Thanks in advance!


  • kiddkidd Member Posts: 1
    I have the same problem.

    Sometimes when we try to print an invoice we get that message "Can not find [database server] ... " If we restart NAV it usually works again, but sometimes a full restart of the WS is needed.
    It happens 0-3 times to something like every 50 invoices.

    It seems to be only on two of our WS:s but not sure because those two are the ones that make the most documents (invoices).

    We have tried things like, new cabels, new switch, "not put network card to sleep" and some other small things.

    Our Microsoft NAV partner had no answer to this, so maybe you guys here have some ideas :)

    Running Windows 7 64 bit on all WS and Windows Server 2008 R2 on servers.
Sign In or Register to comment.