Options

NAV17 / NAV16 SQL failure - could not find the prepared statement with handle

sika_rpsika_rp Member Posts: 4
edited 2023-02-17 in NAV Three Tier
Hello all,

more and more customers with NAV2017 and version NAV2016 get an "could not find the prepared statement with handle".
Sometimes once a month, sometimes every week one time.
Than you can only restart SQL Server services / NAV service to solve the problem.
ocr6fialobwl.png
It starts 1 1/2 years ago with the first customer. Now we have 4 customers with this failure.
Are there other solution centers outside with the same problem and do have a fix for this.
In the internet I do not find solid information about this failure.

Best wishes
Siggi

Answers

  • Options
    Developer101Developer101 Member Posts: 529
    When this error happens? What triggers it or does it happen randomly when operating NAV or does it happen when opening NAV?
    United Kingdom
  • Options
    sika_rpsika_rp Member Posts: 4
    You don't see anything special in the eventlog. The NAV Service works normal - suddenly you see a first statment failure in the log. Then you have 5 to 10 more entries of the same failure and navision is blocked.
    The only solution is to restart the nav & sql service.
  • Options
    Developer101Developer101 Member Posts: 529
    I have not seen this error before but if we can answer below, it might then help to pin point the

    1. Do all users get this error or only few?
    2. Do you have to restart both nav and sql service? Have you tried restarting just one or the other?
    3. After the restart , how long does it take to get this error again. Is there a set time or is it just completely random?
    4. Check sql configuration etc, is there anything out of normal?
    United Kingdom
  • Options
    sika_rpsika_rp Member Posts: 4
    This error occurs at one user. Afterwards other users get the same error on their request and the service is blocked. You can see all errors at the eventlog of the nav server.
  • Options
    Developer101Developer101 Member Posts: 529
    can you share information from the eventlog when the error has happend?. Let us have a look.
    United Kingdom
  • Options
    sika_rpsika_rp Member Posts: 4
    It shoes exactly the same error like on the screenshot.
Sign In or Register to comment.