Unusual behavior calling external web service NAV2013

jeighsohnjeighsohn Member Posts: 7
Hi all,

I've written some functions to call a provider's web service from NAV2013 and process the response. Thanks to great examples found here on Mibuso, it all works... for the most part. Here is where it gets weird.

The first time I run either of the two functions I created after a NAV service restart, it always fails. The second time it is run, it works. The failure message is typically something like (it can vary between this and a more specific ssl/tls message).
Microsoft Dynamics NAV
---------------------------

This message is for C/AL programmers: A call to System.Net.HttpWebRequest.GetResponse failed with this message: An existing connection was forcibly closed by the remote host
---------------------------
OK
---------------------------

Thanks to searching the forum, this appears to be related to TLS/SSL. I've tried adding the below line of code as suggested by other posts on this topic (to specify TLS 1.2), but it doesn't address the issue.
ServicePointManager.SecurityProtocol := SecurityProtocolType.Tls12;

The calls always fail the first time they are run after a service is restart (we restart all of our services every night). Anyone have any other ideas as to what I could try?

One of the calls is initiated by a user (they click an action), and I suppose I could train them to "just try again" but that seems dumb. The other call is run via NAS and it seems to correct itself (since it's a recurring job).


Sign In or Register to comment.