Unable to credit a purchase prepayment

MBClarkeMBClarke Member Posts: 68
Hi,

My client has an issue with trying to credit a prepayment PO. The scenario is below, they are currently running an Azure cloud version. There version is CA Business Central 19.5

The scenario is as follows:

A PO was created and a 100% prepayment was posted. Purchase & Payable setup allows them to receive etc on the PO without paying the prepayment. Once the prepayment invoice was posted, we can see it on the Vendor Ledger Entry table, document PP-13. The warehouse user then went into the PO and realized the PO was wrong, and without checking anything re-opened the PO, changed the quantity on one line and released again.

The finance team picked this up, so they re-opened the PO again, changed the line back to the original quantity and then tried to post a prepayment credit, but when they do that they get errors.

Error is:

Prepayment Invoice must be equal to 'No' in Purch. Inv. Header: No.=PP-13. Current value is 'Yes'

We then tried to cancel the Invoice, or create corrective entries, and each time we get the following error:
Prepayment No. must be equal to '' in Purchase Header: Document Type=Order. No.=PO-10027. Current value is 'PP-14'

What I cannot understand is why is it referencing PP-14, when the prepayment invoice is PP-13? We have searched the entire system and there is no document PP-14. The No. series field for the prepayments has the last number as pp-14, but we cannot find that document. We cannot go into the PO header and remove it either as this is Business Central. When you zoom the PO document there are two fields that reference prepayment, one says 'Last Prepayment No. and that has a value of PP-13, and then another field Prepayment No. which is PP-14, which is the cause of the issue.

Please can someone let me know how to resolve and what one suggests we do to correct?

Thank you for your time.

Malcolm
Sign In or Register to comment.