Services Default Time Zone not working

jordi79jordi79 Member Posts: 230
Hi,
Can anyone every figure out how to get the "Services Default Time Zone" setting in NAV Administration working? I am using NAV2017.

I tried setting this to "Server Time Zone" and also other time zones. But it does not seem to work.

I tested this using web services. When I specify "DateTime" in a web service client, it is always interpreted as UTC.

Jordi

Answers

  • jordi79jordi79 Member Posts: 230
    I still could not get "server time zone" to work. But I found a work around. The problem I had, was I was trying to put in Datetime field values from a SOAP Webservice. And the datetime specified from a webservice is always UTC. To get around this problem I specified datetime in SOAP in the following format:

    <datetime>2002-05-30T09:30:10+06:00</datetime>

    +06:00 is the time zone I am specifying in.
  • RockWithNAVRockWithNAV Member Posts: 1,106
    UTC and Server time Zone are the only 2 Options available, I had used this and it always worked as expected. Make Sure on Case Sensitive part and Service restart once you change.
  • jordi79jordi79 Member Posts: 230
    Hi,
    Still did not work with me. And I tried with with 2 different server instances running NAV version 2017. I tried "Server Time Zone" and also tried the "Windows Time Zone ids", e.g. "Romance Standard Time", "Singapore Standard Time", ....
Sign In or Register to comment.