SOLVED: An error occurred while sending the request. Unable to read data from the transport...

alphaxandraalphaxandra Member Posts: 4
edited 2020-09-24 in NAV Three Tier
Hi,

I'm trying to publish an extension from Visual Studio for BC16. It has worked many times before, but now I am getting this error:

jx0c0eyuivnz.png

The Danish part means: "An existing connection was forcibly closed by remote host."

I've tried repairing the BC installation, restarting service, restarting IIS, but I'm still getting the error. Any ideas?

Answers

  • kylehardinkylehardin Member Posts: 257
    Look at launch.json. Is the authentication method correct?
    Kyle Hardin - ArcherPoint
  • BeliasBelias Member Posts: 2,996
    me and my colleagues (italy) noticed a lot of weird errors trying to publilsh on saas, yesterday. i think there was some kind of maintenance...it looks like it's working now
    -Mirko-
    "Never memorize what you can easily find in a book".....Or Mibuso
    My Blog
  • alphaxandraalphaxandra Member Posts: 4
    kylehardin wrote: »
    Look at launch.json. Is the authentication method correct?

    Yes, it is. The weird part is that it worked before, but then I started getting this error.
  • alphaxandraalphaxandra Member Posts: 4
    Problem solved! I increased Max Upload Size to 1000 in the service settings (not sure if this had an impact) and removed one of the dll files I previously added to the .netpackages folder. Obviously, restarted the service too. All good now :smile:
Sign In or Register to comment.