Development Environment - old 'Server Name'

norsenynorseny Posts: 17Member
Hi,

Do you know how to change the default Server Name in NAV development environment in the window 'Open Database' (File->Database->Open)?
0o0rl27qdihz.png

This is my old server that doesn't exist anymore. It is quite annoying as I have a few NAV dbs on the same server and I have to type Server Name manually every time I open development environment. Version 2017.

Thanks!

Answers

  • PhoguePhogue Posts: 43Member
    Try deleting your .zup file, should be able to find it in C:\Users\yourusername\AppData\Roaming
  • norsenynorseny Posts: 17Member
    edited 2020-01-27
    Unfortunately it didn't help.
    But thanks for the suggestion.
  • vaprogvaprog Posts: 948Member
    edited 2020-01-27
    Check the link you are using to start your development environment. If deleting the .zup file did not help, then nav receives it's connection on the command line, either directly or via a different .zup file.
  • norsenynorseny Posts: 17Member
    Where could another zup file be located?

    The shortcut I run leads to Program Files (x86)\Microsoft Dynamics NAV\100\RoleTailored Client\finsql.exe
    When I run finsql.exe directly, then 'Server Name' is blank in 'Open Database' window.

    I started using shortcuts - commands, like: "...Program Files (x86)\Microsoft Dynamics NAV\100\RoleTailored Client\finsql.exe" SERVERNAME=NEW-SERVER, DATABASE=DATABASE-NAME,NTAUTHENTICATION=1
    However, when I run dev environment using that kind of shortcut, I still see the old 'Server Name' when I open 'Open Database' window. Any ideas?
  • vaprogvaprog Posts: 948Member
    The .zup file is referenced by the ID= parameter. It's value can be a path to the .zup file. If it is a simple name, NAV creates a file with this name and the extension .zup in the folder pointed to by the environment variable APPDATA. IF the ID-parameter is not given, its value defaults to 'fin', thus the default .zup file %APPDATA%\fin.zup.

    I am not sure, but it might be possible to add parameters using the registry.
    Check "App Paths\finsql.exe" in both, HKEY_CURRENT_USER\SOFTWARE\Microsoft\Window\CurrentVersion and HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Window\CurrentVersion and remove any parameters you find there.

    What happens when you call the development environment with parameters a given in your post? Will you be connected to the server given on the command line, or is this ignored? If you get connected to the database given on the command line, there are two possibilities where the old server is stored:
    • in the .zup - close all local dev environment clients, then delete the .zup file
    • it is somehow possible to publish available nav databases, I believe by way of active directory. I have
      never seen any site where this has been done, though, and never figured out how to do it myself.
  • norsenynorseny Posts: 17Member
    When I call the development environment with parameters a given in my previous post, I get connected to the server given on the command line. So my workaround now is to use the shortcut that runs a command with server name specified. Then I select the db manually.

    The interesting thing is that after I:
    1) Delete my .zup file from C:\Users\UserName\AppData\Roaming
    2) Run dev from my new shortcut with specified server name (no db parameter)
    3) Close dev
    4) Run dev again, this time from the standard NAV shortcut
    ... then in dev environment, in 'Open Database' window, server name is populated with the right server name. I can select the right db and it works. However, when I later want to switch to another db, when I open 'Open Database' window, again the old server name is there and I have to type the new one manually.

    When I repeat the above steps with shortcut with both server name and database parameters, then after running dev from standard shortcut I get the standard error saying:
    "The 'OLD_SERVER_NAME' server cannot be found. Try again later or contact your system administrator."

    So I cannot seem to be able to create the right .zup that i could use later as ID parameter.

    Thanks a lot for your help!
  • vaprogvaprog Posts: 948Member
    Sounds rather strange to me.

    One additional thought: there might be something wrong / inconsistent with name resolution. Please check all sources for name resolution for stale entries for the old server (DNS, WINS, host file, NetBIOS master browser, and whatever is involved in IPv6 ad-hoc name resolution).
Sign In or Register to comment.