D365: Symbols won´t download (SSL error) (updated) (solved)

txerifftxeriff Posts: 290Member
edited 2019-12-11 in NAV Three Tier
update 3:

At the end, I closed vstudio tryed again and symbols downloaded. Not sure why ...
but I never managed using docker.

thanks anyway.


Update2:

Hi,

i decided to swtich cloud test account, things look better but still, can´t download symbols! any idea? thanks!

[2019-12-11 15:08:22.66] Using reference symbols cache path: c:\Users\XXXXX\Documents\AL\ALBook\./.alpackages
[2019-12-11 15:08:22.67] Sending request to https://api.businesscentral.dynamics.com/v1.0/sandbox/dev/packages?publisher=Microsoft&appName=System&versionText=15.0.0.0
[2019-12-11 15:08:22.70] Sending request to https://api.businesscentral.dynamics.com/v1.0/sandbox/dev/packages?publisher=Microsoft&appName=System Application&versionText=1.0.0.0
[2019-12-11 15:08:22.70] Sending request to https://api.businesscentral.dynamics.com/v1.0/sandbox/dev/packages?publisher=Microsoft&appName=Base Application&versionText=15.0.0.0
[2019-12-11 15:08:23.43] The request for path /v1.0/sandbox/dev/packages?publisher=Microsoft&appName=System%20Application&versionText=1.0.0.0 failed with code BadRequest. Reason: Bad Request
[2019-12-11 15:08:23.76] The request for path /v1.0/sandbox/dev/packages?publisher=Microsoft&appName=System&versionText=15.0.0.0 failed with code BadRequest. Reason: Bad Request
[2019-12-11 15:08:24.32] The request for path /v1.0/sandbox/dev/packages?publisher=Microsoft&appName=Base%20Application&versionText=15.0.0.0 failed with code BadRequest. Reason: Bad Request
[2019-12-11 15:08:24.32] Could not download reference symbols. Please ensure that:
1. The correct server name and instance are specified in the launch.json file.
2. The correct application version is specified in the app.json file.
3. The dependencies are correctly specified in the app.json file.


All looks good:

"dependencies": [
{
"appId": "63ca2fa4-4f03-4f2b-a480-172fef340d3f",
"publisher": "Microsoft",
"name": "System Application",
"version": "1.0.0.0"
},
{
"appId": "437dbf0e-84ff-417a-965d-ed2bb9650972",
"publisher": "Microsoft",
"name": "Base Application",
"version": "15.0.0.0"
}



Old:


Hi ,

I hope some1 can help.

Im trying to download symbols but for some reason, I can´t.

I get the following error:
The target Page "Customer List" for the extension object is not found ( I guess because symbols are not there yet)

And in output console, it stops in here:

The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.
The remote certificate is invalid according to the validation procedure.




Json file:

{
"version": "0.2.0",
"configurations": [
{
"type": "al",
"request": "launch",
"name": "Your own server",
"server": "https://172.31.250.117",
"serverInstance": "BC",
"authentication": "UserPassword",
"startupObjectId": 22,
"startupObjectType": "Page",
"breakOnError": true,
"launchBrowser": true,
"enableLongRunningSqlStatements": true,
"enableSqlInformationDebugger": true
}
]
}



I downloaded the provided certificate file and installed in windows (docker).

Any ideas?

thanks a lot!


Edit:

I tried to add to hosts file the server, 8e40bd3ccbe6. However, even with certtificate added to the system i get it revoked when entering
https://8e40bd3ccbe6/BC


Error Code: ERROR_INTERNET_SEC_CERT_REVOKED

Answers

Sign In or Register to comment.