BC On-Prem NAVUserPassword Web Client

airamairam Member Posts: 88
Dear All,

I have a BC On-Prem Instance working fine with Windows credentials, both the windows and web clients. However, as soon as I change the credential type to NAVUserPassword, the web client gives me an error of Communication Protocol Mismatch, but the windows client works well.

I followed this blog and it seems I'm missing something in step 7 last point as in the web config file there isn't a key for authentication type. I changed the ClientServicesCredentialType in the navsettings.json file but to no avail.

any help is much appreciated.



  • Options
    SanderDkSanderDk Member Posts: 500
    Hi @airam,
    Do you want the windows client to work with windows credentials and the webclient to work with NavUserPassword? or do you want both client to work with NavUserPassword?
    For help, do not use PM, use forum instead, perhaps other people have the same question, or better answers.
  • Options
    airamairam Member Posts: 88
    edited 2019-09-18
    Thanks for your reply.

    I want both working with NAVUserPassword for now, eventually will try out separate login types, in that case I need 2 separate instances right? but for the time being I need to get both clients working with NavUserPassword

    p.s. not sure if it makes a difference, but my environment is multitenant
  • Options
    airamairam Member Posts: 88
    any tips please? where else should I change the CredentialsType apart from the 'navsettings' and 'CustomSettings'
  • Options
    FiddiFiddi Member Posts: 46
    edited 2019-09-19
    First of all you need a Service- Tier that is configured to use NavUserPassword.
    Then you have to connect and configure your IIS- Nav- Webclient-Instance to use NAVUserPassword and to connect to the new Service- Tier.
    At last you may create new Users in NAV with NavUserPassword or set a password for the already created Windows- User. Then the Windows-Users can login with their "DOMAIN\UserName"- Windows- Username, and the assigned password.
  • Options
    AurSoftAurSoft Member Posts: 3
    Have you set a Business Central password for the account you're using?
    You need to set it before you change credentials type(from the users page).
  • Options
    airamairam Member Posts: 88
    Thanks for your feedback!

    I had already a service configured with NAVUserPassword and set an account with a password.

    I realised now that I had the DNS Identity missing from the navsettings file.

    It is now working, thanks for your replies!
Sign In or Register to comment.