Integer DataItem issue

Kratos3064Kratos3064 Posts: 14Member
Hi,

Recently a client of ours reported an issue with reports (Standard NAV Reports).

1. The rows received was always at 0.
2. After a while (approx 1:20 minutes), NAV threw an error which stated The Server "ServiceName" was unable to process the request. The application will close.

Googling the error showed this usually arises due to Language settings being other than En-US. We found out that both the Server and Client machines were set to the default language (En-US).

On investigating, we found out that some of the customized reports ran smoothly without any errors. Further investigation lead to Integer DataItem being the problem.

We took a standard NAV Report (Customer Top 10) which did not run, we made a copy of it to run tests. I then deleted the Integer DataItem and it was able to run again.

I tried to run Integer table (via Page) and it hung up but I was able to run it locally in my PC. What is the cause for this issue? How can it be resolved?

Answers

  • KlappspatenKlappspaten Posts: 19Member
    edited 2019-08-14
    Does the integer DataItem have a DataItemTableView? If not, the DataItem will execute 4.294.967.295 times (signed integer).

    The reason why it runs on your local machine could be that the server the dynamics nav instance runs on is limited in available ram

    1p8g5uuz316n.jpg
  • Kratos3064Kratos3064 Posts: 14Member
    Hi @Klappspaten , The integer does have a DataItemTableView, It is a standard unmodified NAV report object. Every report object which has an Integer table as a DataItem throws out the error.

    We have a TEST DB for the customer on the same environment and the reports run smoothly. Can this be some sort of application run-time issue for the current DB?

    Thanks for the chart explaining it to me. It used to run, it stopped all of a sudden.

    Edit: We've tried calling the table in a CU. Any form of setrange/setfilter on Integer table is not working.
Sign In or Register to comment.