Docker NavContainerHelper error

TallyHoTallyHo Member Posts: 383
edited 2019-07-23 in NAV Three Tier
Hi folks,

I'm trying to get a NAV/BC container working using docker and NavContainerHelper.
All seems to be going well, but I'm stuck on this error opening the Development environment after installation of the BC (latest) container:

Microsoft Dynamics NAV Development Environment
The following SQL Server error or errors occurred:

-2146893042,"HY000",[Microsoft][SQL Server Native Client 11.0]SQL Server Network Interfaces: no credentials are available in the security package
-2146893042,"HY000",[Microsoft][SQL Server Native Client 11.0]Cannot generate SSPI context
OK

I'm sure this has something to do with the credentials I used when asked for while running New-NavContainer, but
I tried all available users on my computer, and it is still not working.

Note that I'm using a Windows 10 professional system, that is not connected to a domain, and has only local users.

Does anybody know how to fix this?

Best Answer

Answers

  • TallyHoTallyHo Member Posts: 383
    Hi Sander,

    I was using this line:
    New-NavContainer -containerName BCdocker1 -imageName microsoft/bcsandbox:nl -accept_eula -Credential Admin -doNotExportObjectsToText -auth Windows -includeCSide

    But yours is working great, I don't mind navuserpassword.

    Thanks a lot!
  • SanderDkSanderDk Member Posts: 496
    @TallyHo You are welcome :smile:
    For furture referance if you want to use windows login you can map you creditials like:
    $credential = get-credential -UserName $env:USERNAME -Message "Using Windows Authentication. Please enter your Windows credentials."
    And pass this to you container :-)
    For help, do not use PM, use forum instead, perhaps other people have the same question, or better answers.
  • TallyHoTallyHo Member Posts: 383
    Thanks 👍
Sign In or Register to comment.