Custom fields missing in Dynamics BC work in VSCode

aceXaceX Member Posts: 165
Hi there,

After upgrade from NAV 2009 to Dynamics BC, when I try to use some of the custom fields (50000+) in Visual Studio Code from any of the tables, none of this fields doesn't exist in Visual Studio Code when I try to use them from instance variable of that table. Any experience?

Best Regards

Best Answer

  • SanderDkSanderDk Member Posts: 496
    Answer ✓
    Most commen error in this case would be that you have load the BC Standard symbol. But you have not created your new symbol (With your 50xxx fields)
    Try added " generatesymbolreference=1" to your finSQL.exe and set you service tier with "Enable developer service endpoint + Enable loading application symbol referance at startup"
    8c5g20a1ybuu.png

    After you compile your database you should be ably to download symbol in vscode, and acces to your 50xxx fields :-)
    For help, do not use PM, use forum instead, perhaps other people have the same question, or better answers.

Answers

  • SanderDkSanderDk Member Posts: 496
    Answer ✓
    Most commen error in this case would be that you have load the BC Standard symbol. But you have not created your new symbol (With your 50xxx fields)
    Try added " generatesymbolreference=1" to your finSQL.exe and set you service tier with "Enable developer service endpoint + Enable loading application symbol referance at startup"
    8c5g20a1ybuu.png

    After you compile your database you should be ably to download symbol in vscode, and acces to your 50xxx fields :-)
    For help, do not use PM, use forum instead, perhaps other people have the same question, or better answers.
  • aceXaceX Member Posts: 165
    Thank you @SanderDk for your time to help me about this problem. I appreciated.

    The problem was solved when I open the DevEnv with CMD command: location\finsql.exe generatesymbolreference=1and I've compiled the database and synchronized with validation. After redownloading symbols (downloading took a little longer this time) all custom fields was there.


    Best Regards
Sign In or Register to comment.