Error Renaming Company

skalle77skalle77 Member Posts: 6
I'm using Navision Version 4.0. I tried to rename an existing Company (with a lot of data) and retrieved an error "Renaming not possible, Field "Name" of Table "Object" has to be part of the primary key.

Anybody has an idea why this error appears or how it can be solved?

Thanks for your help!


  • Marije_BrummelMarije_Brummel Member, Moderators Design Patterns Posts: 4,262
    Does a DB test on keys come up with strange errors?
  • skalle77skalle77 Member Posts: 6
    No, unfortunately the DB Test doesn't find errors.

    The error still occurs, even if I'm creating a new Database and import all my objects and restore the company, which I would like to rename.
  • 2tje2tje Member Posts: 80
    Strange error.
    Do you have more than 1 company in the same db and perhaps rename the company to an existing one?
    Maybe a workaround, but you could try to make a backup of the company you want to rename (data only!), restore it in a new db, rename it there, backup the company (data only), and restore it in the original db.
  • lolbosslolboss Member Posts: 1

    I'm using a 3.6 Navision Database with an 4.02 engine.
    I have 5 companies with 6 fdb files for a total of 32GB.
    I have exactly the same error when I want to rename a (or all) company.

    Someone have a solution ?

Sign In or Register to comment.