Change Dynamics BC credidentials to SQL Server Authentication fails

FDPFDP Posts: 4Member
I Follow this guide https://docs.microsoft.com/en-us/dynamics-nav/how-to--configure-sql-server-authentication-in-microsoft-dynamics-nav#ConfigNavServer to connect a Dynamics BC instance to an Azure SQL database

running this powershell command: Set-NAVServerConfiguration -DatabaseCredentials $Credentials -ServerInstance $NAVServerName -Force
give this warning:
WARNING: You should encrypt the connection to the database to help protect against network attacks, such as man-in-the-middle attacks.
To encrypt the connection, select the Enable Encryption on SQL Server Connections setting (EnableSqlConnectionEncryption = True) and clear the Enable
Trust of SQL Server Certificate setting (TrustSQLServerCertificate = False).
WARNING: The new settings value will not take effect until you stop and restart the service.

I have set and checked EnableSqlConnectionEncryption = True and TrustSQLServerCertificate = False
I also have runned Import-NAVEncryptionKey

restart of the service don't make any changes.

Manually changing the settings to SQL Server Authentication also reset it back to Windows Authentication.

Do any of you have a suggestion on how to set up af Dynamics BC with a Azure SQL database.

Answers

  • TallyHoTallyHo Posts: 92Member
    edited 2019-02-21
    I've had some issues with this. I remember it had something to do with having
    multiple servicetiers running on the database. I fixed this later with help from google.
    But I got it running with one servicetier at first. (NAV2016)
  • FDPFDP Posts: 4Member
    I get the warning when I try to connect the first service to the database, so I don't' think my problem is about multiple service tiers.
Sign In or Register to comment.