Modify Table with web services

juanbo82juanbo82 Posts: 8Member
Hi!

I need to do changes in table 38 (Purchase Header) from web services but i can't and I don't know why. If i try to modified another table like a test table i don't have problems.

¿Can i see a log error when i'm working with web services?

Thanks


Best Answer

  • juanbo82juanbo82 Posts: 8
    Accepted Answer
    I have managed to solve it, before working in the background I modified table 38 and this caused me the following error:

    "Otro usuario ha modificado el registro de este/a Cab. compra después de leerlo usted.

    Reescriba sus cambios en la ventana actual"

    "Another user has modified the record of this Cab. buy after reading it.

    Rewrite your changes in the current window"

    Now, i modified the table only when i am in the background session.

Answers

  • RockWithNAVRockWithNAV Posts: 730Member
    What's the issue you are facing?
  • juanbo82juanbo82 Posts: 8Member
    I have to post a purchase order from other company.

    For example, i have two companies (Company A and Company B).

    When I'm in company A and press post button, a purchase order is launch and post in company B.

    I have tried three different ways of doing it:

    1.- CHANGECOMPANY --> it only works at the object level, it does not work

    2.- STARTSESSION
    3.- WEB SERVICES

    I have the same problem with 2 and 3. I can change companies but when I make a change in table 38 it does not work. However, when I make a change in a test table if it works.

    The first thing I would like to do is to launch the order with the sentence:

    ReleasePurchDoc.PerformManualRelease(PurchHeader);

    but I can not even make a simple change in table 38...

    Sorry for my english and thank you!
  • juanbo82juanbo82 Posts: 8Member
    Accepted Answer
    I have managed to solve it, before working in the background I modified table 38 and this caused me the following error:

    "Otro usuario ha modificado el registro de este/a Cab. compra después de leerlo usted.

    Reescriba sus cambios en la ventana actual"

    "Another user has modified the record of this Cab. buy after reading it.

    Rewrite your changes in the current window"

    Now, i modified the table only when i am in the background session.

  • RockWithNAVRockWithNAV Posts: 730Member
    So is that Solved completely??
  • juanbo82juanbo82 Posts: 8Member
    Completely!! Now i can post from other company. Finally, I'm working with STARTSESSION.
Sign In or Register to comment.