SQLTimestamp - Extension error

idonavidonav Posts: 22Member
field(50000;"Timestamp";BigInteger)
{
        SQLTimestamp = true;
}

Causes the following error:

"The request for path /nav/dev/apps?SchemaUpdateMode=synchronize failed with code InternalServerError. Reason: Specifying default value for timestamp column"


Any suggestions on how to solve this?

Answers

  • ivarvarovskij@gmail.com[email protected] Posts: 12Member
    Hi, Timestamp is reserved name, use "My Timestamp" etc...
  • Slawek_GuzekSlawek_Guzek Posts: 1,516Member
    @NoOneLt Timestamp is no longer reserved name, as long as you set the SQLTimestamp to true. It gets mapped to existing, normally hidded timestamp field on the table.
    Slawek Guzek
    Dynamics NAV, MS SQL Server, Wherescape RED;
    PRINCE2 Practitioner - License GR657010572SG
    GDPR Certified Data Protection Officer - PECB License DPCDPO1025070-2018-03
  • ivarvarovskij@gmail.com[email protected] Posts: 12Member
    @Slawek_Guzek It changed in AL only?
  • idonavidonav Posts: 22Member
    Same error occurs regardless of what you name it, unfortunately. Any other suggestions?
  • ivarvarovskij@gmail.com[email protected] Posts: 12Member
    Hi again, use "schemaUpdateMode": "Recreate" in app.json tried, it works.
  • idonavidonav Posts: 22Member
    Still receiving the error, regardless if changing schemaUpdateMode.

    "The request for path /nav/dev/apps?SchemaUpdateMode=recreate failed with code InternalServerError. Reason: Specifying default value for timestamp column"

    (+ I'd rather avoid using the recreate option)

    Then it must be something else. Can't really come up with what. Did you try it in a docker setup @NoOneLt ?
  • ivarvarovskij@gmail.com[email protected] Posts: 12Member
    edited 2018-06-21
    Yes iam on docker bcsandbox image. You could try to update your docker image, remove old image before and update container. I had it 5 weeks old and "Recreate" worked.

    Yesterday i updated image/container and iam able to have this table even with "Syncronize"

    table 50100 MyTable
    {
    DataClassification = ToBeClassified;

    fields
    {
    field(1;MyField; Integer)
    {

    DataClassification = ToBeClassified;
    }
    field(2;MyTimestamp; BigInteger)
    {
    SqlTimestamp = true;
    }

    }
  • idonavidonav Posts: 22Member
    Still same issue, running a table extension, anyone feel like trying creating a table extension containing an sql timestamp? Preferable table 36.
Sign In or Register to comment.