Problem on Compiling Tables

EkinEkin Member Posts: 28
Hello Everyone,

I'm having an issue on compiling tables. Development Environment is unable to see NAV service.

Our architecture is :

Azure SQL Server : Machine A
Azure NAV Server : Machine B
Azure Server : Machine C

We are able to compile tables when we use development environment in Machine B where NAV Server and Services are installed. However, we are not able to compile tables (We can compile other object types). We are planning to use Machine C for development because of various reasons such as Disk Space, reduce number of signed users (Memory usage) etc.

We have opened Management Services port from Azure Portal, and set the outbound rule for the port in Machine B. We have also tried to change server name in SQL Table instead of localhost but we still not able to compile tables.

The only solution have come in our minds is to change Machine C to NAV Server, create a second service for every database and use that service for development and table compilation.

Do you have any other suggestion?



  • Options
    JuhlJuhl Member Posts: 724
    Open port 7045
    Follow me on my blog juhl.blog
  • Options
    EkinEkin Member Posts: 28
    edited 2018-02-26
    Juhl wrote: »
    Open port 7045

    Our Management Port service is not 7045, we are using 7645 for that specified database. And the port is open.
  • Options
    afarrafarr Member Posts: 287
    When you try to compile tables, do you get any messages or errors?

    Check the Event Viewer too (Application log), since there may be more detailed messages or errors there.

    And make sure that you're using finsql.exe from the folder "RoleTailored Client". By default, for Nav 2017 this is:
    C:\Program Files (x86)\Microsoft Dynamics NAV\100\RoleTailored Client

    We once used a finsql.exe that can be found in the Service folder, and encountered problems when trying to save objects.
    Alastair Farrugia
Sign In or Register to comment.