NAV 2017 - Dynamics365 v9.0.0.3172

ma7eooma7eoo Posts: 7Member
Hi,

I have problem with connect to CRM (version 9.0.0.3172). I'm getting the following error:
ffx0ujhppil0.png
Problem is only when i want to connect with version 9.0 (with version 8.1 everything work fine).

Did anyone have a similar problem ?



Programmer from Poland.

Answers

  • marcussulicmarcussulic Posts: 15Member
    Same issue with NAV Versions 2016 and 2017. Before Christmas it was fine. Do you know when exactly the issue started? Was it fine on the 8th for example? Have you tried contacting Microsoft? Please update if you find anything and so shall I.
  • ma7eooma7eoo Posts: 7Member
    I have new information. This problem occured because now Dynamics365 (from v9.0) accept connection only with TLS 1.2 (disable protocols TLS 1.0 and TLS 1.1). NAV 2016, 2017 and 2018 (before CU1) use TLS 1.1. In NAV 2018 CU1 integration work correctly, because NAV use TLS 1.2

    Probably within a few days MS team will publish hotfix for this bug.
    Programmer from Poland.
  • marcussulicmarcussulic Posts: 15Member
    Thank you very much for this info.
    Did you contact Microsoft on this or how exactly did you find out if I can ask you that? Even with searches involving CRM and TLS1.2 I couldnt find any Microsoft posts about it.
  • marcussulicmarcussulic Posts: 15Member
    Just installed the Hotfix on my CU 20 and it still doesnt work....
    I uninstalled the NAV Server and installed it again and the connection doesnt work. Whats strange is while installing Server from the Hotfix DVD ... it asks for Service Tier msi file and doesnt accept the one in the Hotfix DVD. So I manually installed it and created new Server instances with the new Server Version 9.0.49832 and everything seems to be updated besides that the CRM Connection still fails with the same error.

    @ma7eoo, did you manage to fix it? you also stated that it works fine with Dynamics 365 version 8.1, how can you switch it or check what version you are using? i thought it updates automatically

    p.s. Its a Hotfix version above the latest CU 27 and will probably be a part of CU 28. Sucks big time that you have to abandon your stable older CU to be able to use connect to CRM again...
Sign In or Register to comment.