Limited User Weird Behavior When Update Item Unit Of Measure

hollydonuthollydonut Posts: 24Member
Hi All,

I have encountered weird behavior when updating Item Card's base unit of measure.
I am using nav 2017. I have configured a Limited User.
The user can created a new Item, but the problem is when i fill field base unit of measure, the user get an error of "“You do not have the following permissions on TableData Item:Modify".
This error is not showed when i modify other field, such as description.
Does anyone have the same problem? How do you resolve this ?
Thanks in advance.

Best Answer

  • hollydonuthollydonut Posts: 24Member
    Accepted Answer
    My functional have tried to fixed this by try to create a new DB and restore the company data without Global and Application data then reupload the profiles. And somehow it works. But the cause is still unclear.
    Thanks All.

Answers

  • neilgfneilgf Posts: 130Member
    Hi. As base unit of measure is a separate table you will permission to add a new record there. Neil
  • hollydonuthollydonut Posts: 24Member
    hi neilgf,

    isn't limited user have permission to write up to 3 tables? based on this article https://msdn.microsoft.com/en-us/library/jj551750(v=nav.90).aspx

    So it should be ok right?
  • Jan_VeenendaalJan_Veenendaal Posts: 185Member
    The table limit is per session. NAV counts the tables that are modified by the user (only tables that are not 'free' tables - see the licensing guide for a list of Included Tables). So, sometimes you hit the limit on a table, while you can modify the same table in another session. The 4th table that you try to modify will hit the limit.

    Please be aware that AFAIK the 'limited user' license is not only limiting the number of tables, but also the types of tasks that are allowed.
    Jan Veenendaal
  • hollydonuthollydonut Posts: 24Member
    Hi Jan,

    When i test , i directly go to the item list then find my item, then edit the Base Unit Of Measure, so my rough estimation i only hit two tables. I have check the code, no custom table is triggered when Item Card is modified.
    But i still get the permission error.
    What is the problem?
  • sorenhinrupsorenhinrup Posts: 47Member
    If your user has permissionsets setup, then these have to allow the user to modify the data.
    Alternatively there might be something else that writes in tables for the user when entering the application. I think it might be the first issue, as your user can add the record into the table, but not modify it.
  • iSadiSad Posts: 4Member
    Hej @hollydonut . Did you get this sorted ? I think MS might have a problem here. In 2017 RTM, I can only get 2 tables for a limited user.
Sign In or Register to comment.