NAV2017 Control Add-In Automated Deployment

Hi to all,

I am still a newbie in developing and deploying add-in. I am trying to understand they way to deploy dll automatically. I tried all the steps here:

https://kauffmann.nl/2014/09/24/nav-2015-automatic-deployment-of-net-assemblies/

I used a small add-in I found online, the Bing map, with the following interface:
s3um15gln1aq.png

Saved, built the ddl, signed and deployed in the add-in folders (both client and server in the development environment, but I tried also to deploy just on server side).
b5uxwtx7tll2.png


I registered it in NAV:

pldc0fuxgn0v.png

The add-in is "called" in a NAV Page:

0a6fju388myc.png

Now, if I run the add-in page on development server, it works well with RTC client and Webclient

o6wif0kc7xhr.png

I tried on another server, with NAV2017 installed, without deploying the dll, and the add-in doesn't work with RTC (It works with WebClient)

9y5swte4nx94.png

The error pop up just if I try to change latitude, because it calls a method "load" in the add-in class (In the development environment it works).

Any idea how to solve this problem? :s Maybe it is something simply but I can't get it.

I hope information is enough.

Thanks in advance.
Davide






Comments

  • PureHeartPureHeart Posts: 187Member
    Hi Davide,

    I'm experiencing the same behaviour in NAV 2017 I'm sure it was working fine in NAV 2015 and NAV 2016? Anyone has got the same problem?

    Cheers

    Taddeo
    Why don't you try my compare tool?
    http://www.mibuso.com/dlinfo.asp?FileID=1123
  • davide.mazzilli@infostudi.it[email protected] Posts: 10Member
    Hi Taddeo, after ur post I tried in a NAV2016 environment, and, gosh, u are right. All WORKS! :s
    It is something related to NAV2017. I will probably open an incident in Microsoft
  • PureHeartPureHeart Posts: 187Member
    Hi Davide, yes must be related to NAV 2017. Let us know what Microsoft says!

    Ciao!
    Why don't you try my compare tool?
    http://www.mibuso.com/dlinfo.asp?FileID=1123
  • davide.mazzilli@infostudi.it[email protected] Posts: 10Member
    I tried to download the last cumulative update (6) I found, before opening the incident (Sometime it takes too much time explain all for an incident, with an example). Until now, I tested the client in a 3 level environment on 3 machines and It works.

    So, for a Javascript Add-in, the CU 6 resolve the issue.

    I still have problems with a pure C# add-in with automated deploy. All good in the developing environment, even if the dll is just in the server addin folder, but It doesn't work on a 3rd machine. Maybe the dll size is too big (117KB) :(

    Honestly I am having problems, different, with an older add-in too, the first one I did, that showed me how to use many events. It is a winform with fixed controls. Even if it looks similar to other addins, with assembly name exactly equal to the addin name and small size (13KB), it works just if I put the dll in the client directory, also in the developing environment :s :s :'(
  • davide.mazzilli@infostudi.it[email protected] Posts: 10Member
    Anyway I suggest to test the update in a different environment. I am having trouble in updating the server files as described here
    https://support.microsoft.com/en-us/help/3204818/how-to-install-a-microsoft-dynamics-nav-2017-cumulative-update Manual Patching process

    Literally the server doesn't start with an error (Event viewer) on KERNELBASE.dll

    Faulting application name: Microsoft.Dynamics.Nav.Server.exe, version: 10.0.16585.0, time stamp: 0x59028880
    Faulting module name: KERNELBASE.dll, version: 10.0.14393.479, time stamp: 0x582588e6
    Exception code: 0xe0434352
    Fault offset: 0x0000000000017788
    Faulting process id: 0xb10
    Faulting application start time: 0x01d2cfe88272ef40
    Faulting application path: C:\Program Files\Microsoft Dynamics NAV\100\Service\Microsoft.Dynamics.Nav.Server.exe
    Faulting module path: C:\Windows\System32\KERNELBASE.dll
    Report Id: 7cef783b-e6cf-4283-a44b-55b641427741
    Faulting package full name:
    Faulting package-relative application ID:


    Restoring previously saved file make my server start again. Now I am investigating this problem

  • PureHeartPureHeart Posts: 187Member
    Davide,

    The solution to have the assembly deployed automatically is to have the name of the assembly file exactly match the name as defined with the ControlAddInExport attribute within the assembly.
    For example: if your control add-in is named MyCompany.AddIns.SomeFantasticControl, then the assembly name has to be MyCompany.AddIns.SomeFantasticControl.dll

    In bocca al lupo!

    Taddeo
    Why don't you try my compare tool?
    http://www.mibuso.com/dlinfo.asp?FileID=1123
Sign In or Register to comment.