Sync Error : Invalid column name 'Base Hash'

tejateja Member Posts: 78
edited 2017-05-08 in NAV Three Tier
HI all,

While upgrading the DB from NAV 2015 to NAV 2017 CU 2.1, the below error is coming.

we have converted the DB to NAV 2017 after converted, we have imported the Application objects and upgrade tool kit objects with sync option later, then we are trying to sync db with Option :: Validation.

we are trying the below steps :

https://msdn.microsoft.com/en-us/dynamics-nav/upgrading-the-data



The following SQL error was unexpected:
Invalid column name 'Base Metadata'.
Invalid column name 'Base Hash'.
Statement(s) could not be prepared.


SQL : 2012

please suggest on this issue


Thanks & Regards,
Teja . G

Best Answer

Answers

  • tejateja Member Posts: 78
    Hi MoebelMeller,

    sorry for the late reply. But your suggestion worked. Thanks for the quick reply.
  • AitorEGAitorEG Member Posts: 317
    edited 2017-06-30
    Hi Teja,

    i had the same problem, here's the solution:

    I guess you have converted the database - like me - by opening the Dev-Client not in Administrator-Mode. This is necessary, that the error doesn't appear.
    Anyway, what you have to do right now is, to open the SQL-management-Studio, select the table "Metadata Snapshot" and add the 2 columns "Base Metadata" (type=image) and "Base Hash" (type=nchar(32)).

    After that you should be able to compile your objects with Validation.

    Best Regards

    Hello,

    Sorry for opening this issue again, but I found this post when I found myself in the same problem.
    I've tried to convert the database openin the Dev Env in administrator-mode, but the erros still occurs.
    I'm trying to finde the "Metadata Snapshot" table in SQl, but I can't find it. Where is this table?

    THank you for you help, really appreciate

    edit: I've found the "Objetc Metadata Snapshot" table, and it has both fields yet:
    t3pbjhe1lav5.png

    So it looks this is not the problem....
  • kalyankandimallakalyankandimalla Member Posts: 56
    Hi,

    Can you please stop, start the service and try to run the synch. again.
    We too had the same issue, but after adding the fields and restarting the service worked in our case.
  • robintheswederobintheswede Member Posts: 12
    Thanks @MoebelMeller, it worked for me by simply adding the two columns in SQL (the table name was 'Object Metadata Snapshot') and restarting the NST.
Sign In or Register to comment.