Options

NAV 2009 R2 Build 32012

lubostlubost Member Posts: 618
I need to implement Navision server for RTC, but small success. Steps:
1. Created VM (WS 2008 R2) and install NAV 2009 R2 from installation media - with NAV Server
2. Service installed and run with NETWORK SERVICE account (DynamicsNAV)
3. Edited configuration xml in Service directory to change SQL Server and database to my test database (service account mapped to this database and added as user with SUPER permission)
4. Restarted service DynamicsNAV
5. Local RTC works perfectly
6. Remote RTC can not connect due to error Login failed for user <domain name>\Anonymous. Afterwards I tried to add SPN for service DynamicsNAV, but I can not do that, because I didn't see this service in AD console (firewall is off)
7. I had read, that can help when SQL Server and NAV Server service bot run under the same domain account. Then I changed accounts for SQL Server service and NAV service to the same administrator account - no success
8. I tried to install SQL Server 2008 R2 on VM with NAV Server - no success

All accounts are in the same domain

What's wrong? What's to do?
I am able to do TeamViewer session to help to investigate my environment.

Thanks in advance

Answers

  • Options
    ftorneroftornero Member Posts: 523
    I can try to help you out if you want to.

    Regards.
  • Options
    endjinnendjinn Member Posts: 11
    You need to sort the SPNS. This is a typical NAV 2009 issue as the old version required that you set the spns manually. In the newer versions this is done for you automatically. Here are instructions on how to do it:

    https://dynamicsuser.net/nav/b/kine/posts/dynamics-nav-2009-and-spns

    Lastly you should run NAV with a domain user service account and set the SPN against this account.

    Hope this helps!
  • Options
    lubostlubost Member Posts: 618
    Thank you endjinn, something happens and my next error message opening RTC:

    A call to SSPI failed, see inner exception

    What next?

    Thanks in advance
Sign In or Register to comment.