Options

Start Automatically From NAS not working

aceXaceX Member Posts: 166
I have one confusing problem with Dynamics NAV 2015 / 2016.
I have created few job queues in NAV. In each of them I checked Start Automatically From NAS feature. But, after server or service are restarted, non of the job queues are not starting. Then, I need to go in Job queues list, open one by one, uncheck Start Automatically From NAS, start the job manually.
Does any one have idea what I'm missing in setting up this feature?

Thanks in advice
Best Regards

Comments

  • Options
    postsauravpostsaurav Member Posts: 708
    Hi,

    Make sure when you set Start Automatically From NAS, You also select the -
    "Start on This NAS Computer" and
    "Start on This NAS Instance"

    So Even after restating the service, Job Queue will update based on service which is selected.

    Thanks & Regards,
    Saurav Dhyani

    Do you Know this About NAV?


    Connect - Twitter | Facebook | Google + | YouTube

    Follow - Blog | Facebook Page | Google + Page
  • Options
    mikhaelmikhael Member Posts: 19
    Hey

    Have you setup the NAS settings in the NAV service? Startup argument (JOB QUEUE) + startup codeunit no (450)?
  • Options
    aceXaceX Member Posts: 166
    Everything is set, bit it still not working. I can't find anything on any forum or manual what I need to do plus for this to work automatically. Maybe I'm doing something wrong, for that reason I'm sending in attachment pictures of settings.

    Thank you for your time
    Best Regards
  • Options
    mikhaelmikhael Member Posts: 19
    Hmm has the NAV Service account permissions to NAV?
  • Options
    aceXaceX Member Posts: 166
    Absolutely, the same service is used from users who work from LAN in the company (same domain).

    I have totally the same problem with NAV 2015, but there server is restarting twice in a year max, so I'm starting the jobs manually. But on this server, client is restarting the server almost every day :neutral: (they shut down the server after work time, I can't understand why ... but that's their politics)..

    Every idea for this problem/(bug maybe) is welcome.

    Thanks for your time
    Best Regards
  • Options
    mikhaelmikhael Member Posts: 19
    Have you set startup company name in the Service setup (I am not sure if this affects at all but I have always set it ). Are you able to run any codeunits via NAS service, if you cust create some test codeunit, put that in the Startup codeunit field and trying to start the NAS service?

  • Options
    zychzych Member Posts: 20
    Have you check event viewer for any error ?
  • Options
    aceXaceX Member Posts: 166
    Yes @zych, I've checked Event Viewer. No error shown, not even warning about NAV Services :(

  • Options
    ErictPErictP Member Posts: 164
    Do you have 'strange' characters in the 'Services Default Company'?
    I also had trouble with the automatically starting of the NAS and this was because there was a & character in the companyname.

    After switching the 'Services Default Company' to an other company with only 'normal' characters, the NAS automatically starts in all companies.
  • Options
    DsmithDsmith Member Posts: 7
    I've run into this recently where I had 2 NAS services setup to run for 2 companies.

    I had the Job Queues and NAS setup with the correct startup fields filled, but the Job Queue would not connect/start for the correct service.

    After several different variations on my setup, my solution was to enable the job queue in one company without the Start on This NAS Computer and Start on This NAS Instance fields filled, then start the corresponding NAS. Once I confirmed the Job Queue started and using the correct NAS instance, I repeated the steps on the other company.

    I'm not sure why specifying the startup fields in the Job Queue didn't work.
  • Options
    zychzych Member Posts: 20
    Try to remove the Startup Argument value
Sign In or Register to comment.