Options

Where is the path to RTC client stored when you run objects from Development Environment?

BorisKBorisK Member Posts: 45
Since beginning of this week we started experiencing a problem on NAV2013R2 (build 37563) system whereby we can't run anything from the Development Environment - it immediately errors saying "Microsoft.Dynamics.Nav.Client has stopped working..." It worked until last weekend, and the only thing we see has changed is that .NET Framework security update was installed on Saturday. Event Viewer shows an error quoting faulting application path to Microsoft.Dynamics.Nav.Client.exe. The path is the full network path to the client folder, so our guess is this must be some permission issue. However the client is actually installed on the same server where we are running Development Environment, so the system doesn't have to follow the network path. So the question is: does anybody know if the path to NAV client is stored in an editable configuration file (or Table) anywhere? We just can't find it.
And yes, we tried the workaround of running Development Environment as administrator - oddly it worked a few times, and then it stopped, now giving us the same error!

Best Answers

Answers

  • Options
    vaprogvaprog Member Posts: 1,128
    I don't know all the details, but usually the Dev Client checks if there is a client already running. If not, it starts searching for the RTC in the directory the Dev Environment executable (finsql.exe) is started from.
    As far as I know, there is no configuration file for this. If nav cannot figure out, where the RTC is to be found from process data, it might try the registry. I'd start checking the registered URI schemes dynamicsnav und navision.

    Your installation should not be on a mapped network drive if you use "Start as Administrator", as drive mappings are not propagated between the different privilege levels, and generally you should not use UNC paths either. Please check the link or script from which you start the Dev Environment.
  • Options
    BorisKBorisK Member Posts: 45
    Thank you for coming back to me, vaprog.
    I checked all of this and still no avail I am afraid.
    Both Dev and RTC client are installed in the same folder.
    It's weird, but even if RTC is already running, trying to run an object from Dev client brings up the same error!
    It just doesn't recognise the running RTC instance and tries to start it again, but for some reason from a network path.
    I made sure the Server Address in running RTC instance is exactly the same as Server Name, Server Instance Name and Server Port stored in Tools -> Options in Dev client.
    I went through all the registries looking for the network path as quoted in the Event Log, found a couple (presumably unrelated as they were in ...\Windows\CurrentVersion\Explorer\TypedPaths\url3), changed them anyway but it didn't make any difference.
    I then ran another search for dynamicsnav, as you suggested, but whatever it found always had the local path in it.
    So still stumped :/
  • Options
    BorisKBorisK Member Posts: 45
    Hi vaprog

    I didn't mean to mark your answer in any colour! :)
    All I did was select "No" where it said "Did this answer the question?"
    Now having read it again I can see that your last sentence pointed me in the right direction, it's just I didn't identified "link or script" with the property of the shortcut for RTC in Programs.
  • Options
    mohana_cse06mohana_cse06 Member Posts: 5,504
    It will run the RTC client depends upon path here
    [HKEY_CLASSES_ROOT\DYNAMICSNAV\Shell\Open\Command]
  • Options
    Big_DBig_D Member Posts: 203
    Hi mohana
    Thanks for your registry link HKEY_CLASSES_ROOT\DYNAMICSNAV\Shell\Open\Command\
    This works great if have just one RTC client installed but if have many then am guessing it is just finding the first!
    Any way to do a registry search on a specific RTC?
    With thanks
    Big D signing off!
  • Options
    Big_DBig_D Member Posts: 203
    Hi mohana
    Okay found my own answer
    http://forum.mibuso.com/discussion/54136/how-to-get-the-path-of-the-roletailored-client

    The trick to set the DotNet Variable "Assembly" to True for RunOnClient, needs this for the Path too otherwise it mirrors the result of the APPLICATIONPATH.
    Also had to Copy the DotNet parameters as the lookup came back nil!

    Good luck!
    Big D signing off!
Sign In or Register to comment.