ADCS: HyperTerminal connection problem

smilso20smilso20 Posts: 5Member
Hi all,

I try to connect to NAV with HyperTerminal but doesn't work, this is the error message:

"Error sending message to Nav: No active message processors listening on the message queue".

could someone suggest me how to solve?

Thanks

Answers

  • Peter+is1Peter+is1 Posts: 174Member
    How to: Configure ADCS Options

    Microsoft Dynamics NAV 2016
    Before you can work with Automated Data Capture Systems (ADCS), you have to configure Microsoft Dynamics NAV by modifying the VT100Plugin configuration file.
    \\
    The truth exists in seven versions.
  • parmparm Posts: 49Member
    Hi,
    I agree with Peter+is1.
    Please confirm that you have configure the ADCS and try to clarify which step is failing.

    regards,
    parm
  • smilso20smilso20 Posts: 5Member
    edited 2016-06-27
    Thanks Peter,
    I configured just as explained in the microsoft website (https://msdn.microsoft.com/en-us/library/hh167649(v=nav.90).aspx) but doesn't work.

    Before making the setup I could not even connect because the error message reported "was connection timeout".

  • Peter+is1Peter+is1 Posts: 174Member
    Hi,

    Have you published the “ADCS WS” codeunit as web service?
    \\
    The truth exists in seven versions.
  • smilso20smilso20 Posts: 5Member
    ehm no,

    what you mean?
  • Peter+is1Peter+is1 Posts: 174Member
    In NAV you need to enable the web service LINK

    good luck.
    \\
    The truth exists in seven versions.
  • smilso20smilso20 Posts: 5Member
    Hi,

    I followed the guide and published codeunit ADCS but I have not solved the issue.

    It is very strange because in other installations I've never had this kind of problem.
  • kylehardinkylehardin Posts: 159Member
    Did you test hyperterminal on the NAV Service Tier itself? You may also have to make a firewall rule opening whatever port the ADCS service is using.
    Kyle Hardin - ArcherPoint
  • smilso20smilso20 Posts: 5Member
    This is the message error in the Event View:
    "Description: Error in the communication: no endpoint listening on http: // lenovo-pc: 7047 / DynamicsNAV90 / WS / CRONUS% 20International% 20Ltd / codeunit / ADCS able to accept the message. This is often caused by an action SOAP or an incorrect address. For more details, see InnerException, if present."
  • kylehardinkylehardin Posts: 159Member
    Did you enable SOAP web services in the NAV Admin tool?
    Kyle Hardin - ArcherPoint
  • Peter+is1Peter+is1 Posts: 174Member
    I would suggest you uninstall everything -nav, vt100 - and start over. This adcs is really quite easy to setup in 2016 and you may have turned something of in firewall or iis that we cannot see.
    \\
    The truth exists in seven versions.
  • kylehardinkylehardin Posts: 159Member
    Not sure I would go the whole nuke-from-orbit route and start over.

    Troubleshooting ideas:

    Check the firewall where the VT100 service is running. The config file for that service will tell you what port it is listening on. Make sure the firewall allows inbound connections on that port. You can test this by first telnetting on the VT100 server itself (this should bypass the firewall, but makes sure the port is actually listening). Then test telnet from another system to the vt100 server with that same port - this tests the first firewall rule.

    telnet vt100server 6666

    Once this is working, then move one spot closer to NAV. The VT100 service makes web service calls to the NAV Service Tier specified in the config file. Use the NAV Admin Tool and make sure SOAP is enabled (defaults to port tcp:7047), and that the ADCS Codeunit is published inside of NAV as a web service. You can test this by running IE on the NAV Service Tier and going to the URL like this:

    http://nav-service-tier:7047/DynamicsNAV90/WS/CRONUS% 20International% 20Ltd/codeunit/ADCS

    Once that it working on the NAV service tier, check the NST firewall rules and make sure that port 7047 is enabled inbound. Test from another system to that same URL.

    When you get those pieces working, including the firewalls, you should be good to go.
    Kyle Hardin - ArcherPoint
  • malintusmalintus Posts: 14Member
    I had the same problem but nothing of mentioned things didn't worked. My problem with this started when date of certificate was expired. When I update the certificate, and update certificate hash code in ADCS instance this message was occured. The reason of message: cartficate hash code I did put in lowercase letter. it was strange because normally if hash code is wrong there is a messege but if you put lowercase letters there is no error. I enetred hash code in uppercase letters and message stopped showing up.
Sign In or Register to comment.