File.CREATE:Either the caller does not have the required permission or specified path is read only

MJVMJV Member Posts: 38
In the RTC in NAV 2016 we have a report that writes to a file. the call to FILE.CREATE() is emitting the error
Either the caller does not have the required permission or the specified path is read only.
for testing purposes, I tried both a special network share and a path on the server machine itself that I shared wide open with full control for all users, and I still the error.
I explicitly made sure that the nav service running NAV has rights to the trial folders, as well as the login I am running the RTC with.
I can manually place files in the trial folders with my account.
Can anyone think of permissions that might be needed elsewhere by another account?
I have seen the discussions for this error for when the users cannot run the RTC because of this error, and I am wondering if some temporary file is being used by the RTC before actually writing to this file.
Our users have no issues running the RTC in this installation, so the service folder is probably shared correctly.
Thanks in Advance!


  • Options
    MJVMJV Member Posts: 38
    For a solution, we just opened up the directory to Public. I am thinking we could have run it with the tighter permissions, and tried looking in the Event Viewer to see if an error registered there and if so, what account name was involved....
  • Options
    kylehardinkylehardin Member Posts: 257
    File.Create is going to run on the NAV Service Tier, using the active directory (or local) account that the service is running under. You said you made sure that the NAV service has rights to the trial folders - how did you test that? If you can log onto the NST server as that service account, you can do a test with Windows Explorer and verify the access. What kind of account is that service using? Is it NETWORK SERVICE?
    Kyle Hardin - ArcherPoint
  • Options
    MJVMJV Member Posts: 38
    Thanks so much for you response Kyle!
    I know that every box has an account matching the name of the box, so we gave that account permissions to the file share and the problem was solved.
Sign In or Register to comment.