[NAV2016] Run object from development envirnoment not reusing opened RTC client anymore in Update 5?

davorpdavorp Member Posts: 17
edited 2016-03-15 in NAV Three Tier
I just installed NAV 2016 CU5 (build 45243) and now when I run an object directly from the development environment it no longer opens in an RTC client connected to the same instance, but is always starting up a new RTC client, which is rather annoying when doing development.

Did anyone else notice a similar problem?

Here are the fact as I know them:
1. I have multiple NAV installations, 2009/6.0, 2013/7.0, 2013R2/7.1, 2015/8.0 and 2016/9.0 on the computer (Win8.1) and all were working ok last week.
2. Running a Page from NAV 2016 dev. env. was opening in current RTC client while I had 2016 CU2 installed (build 43897)
3. Running a Page from NAV 2016 CU5 dev. env. is not opening in currently opened RTC client anymore
4. Running a Page from NAV 2015 dev. env. (CU12 build 42951) is also not opening in currently opened RTC client anymore (but was working last week)
5. Running a Page from dev. env. is still working as expected from NAV 2013/2013R2 (both are much older builds)

Can someone please confirm if this is still working for them with their installation of NAV 2016 with cumulative update 3 or greater?


  • Options
    davorpdavorp Member Posts: 17
    I think I found out what was going on.
    For reusing an already opened RTC client when running an object from development environment you need to have a certain .dll library file registered on the system.
    The file in question is Microsoft.Dynamics.Nav.Client.WinForms.dll located in Roletailored Client installation directory.
    The file should get registered during installation. However I did an uninstall of NAV 2016 CU2 before installing NAV 2016 CU5 and I suspect this somehow messed things up.

    After manually registering .dll using regasm.exe I can now again run objects from development environment in the currently opened RTC client.

    I opened command prompt as Admin and executed:

    c:\Windows\Microsoft.NET\Framework\v4.0.30319\RegAsm.exe "c:\Program Files (x86)\Microsoft Dynamics NAV\90\RoleTailored Client\Microsoft.Dynamics.Nav.Client.WinForms.dll" /tlb

    This solved the problem for NAV 2015 as well as NAV 2016.

    The following link was helpful debugging this issue (although it deals with problems related to side-by-side running of NAV2013/NAV2013R2)
    Installing Microsoft Dynamics NAV 2013 R2 side-by-side with Microsoft Dynamics NAV 2013

    So, back to business as usual now ;)
Sign In or Register to comment.