General journal does disappear when posting

michellekmichellek Member Posts: 1
I have repeatedly experienced the same error in NAV 2016. (Build 43897) with various of out customers. Are there others who have encountered this:
By posting and printing of general journal the draft entries do not disappear from the journal after posting!! The entries are though posted in the system on customers, vendors, general ledger, etc. BUT there is not formed any G/L Registers. When posting the users get an error like "There is nothing to post", "General posting type is missing" etc., Which will normally stop the posting process, but that is not the case here.


  • Options
    krikikriki Member, Moderator Posts: 9,090
    [Topic moved from 'Navision Financials' forum to 'NAV Three Tier' forum]
    Regards,Alain Krikilion
    No PM,please use the forum. || May the <SOLVED>-attribute be in your title!

  • Options
    CHJustesenCHJustesen Member Posts: 1
    I have experienced the exact same behaviour in NAV 2016 build 43402 a few times at random. I am not able to reproduce the behaviour though, which makes it extremely hard to debug.

    Michellek, are you able to reproduce the behaviour and did you find a fix?

    Would be great, if anyone else have experienced the same problem and could supply with information.
  • Options
    AntidotEAntidotE Member Posts: 61
    I believe this is linked with nav 2016 feature Preview Posting and all new stuff introduced.
    You should document as much info as possible and notify microsoft support about this.
    It is hard to swim against self bloodstream... (c) Old, experienced kamikadze.
  • Options
    xtnxtn Member Posts: 1

    I am facing the same error right now. Could somebody know how to resolve this issue. Please advise.

    Thanks in Advance.

  • Options
    YokoYoko Member Posts: 1
    Please looked at


    ID 377725

    When you use the Preview Posting function from a general journal with insufficient settings, G/L ledger entries are created but no G/L register and the posted general journal lines are not deleted.
  • Options
    EgisEgis Member Posts: 10
    We face the same issue randomly in a few deployments (NAV 2016 with CU2).
Sign In or Register to comment.