NAV 2015 Synchronize Schema Changes

RoelofRoelof Member Posts: 362
I'm currently in an upgrade to NAV2015 (build 41779) and I'm running the 'Sync. Schema for All Tables'. It ran for a while and currently the progression bar is at 100% for some hours now but the 'State' is still saying 'OperationalSyncInProgress'. The database to convert is a large database but I'm getting a bit concerned how long this process should take. I would assume that the 'State' field would mention when the whole syncing process would be completed, wouldn't it?
Roelof de Jong
http://www.esopro.com

Answers

  • mohana_cse06mohana_cse06 Member Posts: 5,469
    state field will be Operational once the process is finished.
  • RoelofRoelof Member Posts: 362
    But how long can this take and is there a way to monitor the process?
    Roelof de Jong
    http://www.esopro.com
  • aman_mbsaman_mbs Member Posts: 158
    Hi Roelof did you got some success on this problem even I am facing the same.

    Regards,
    Aman
    Aman Kumar Gupta
  • RoelofRoelof Member Posts: 362
    Hi Aman, yes I did. Out of experience I noticed that you actually synchronize with force all tables as soon you're in NAV2015. That shouldn't take that long since no changes have been made (objects are the same). The status should say: Operational. Then, when you import all customizations, you synchronize with CheckOnly. It will tell you if there are any error. Run the synchronization only from the prompt in the admin shell. In that case you can control the process much better. When all errors are fixed or no error are found you run the synchronization with Force. At some point it looks like the process has been completed and you come back to the prompt. However, the status still might say: 'OperationalSyncInProgress'. Let the process continue in the background and check in once a while until the status is saying: Operational.
    Roelof de Jong
    http://www.esopro.com
  • kvbkvb Member Posts: 97
    edited 2017-05-12
    I had same issue several times, but only now find the answer.
    System freezes at the 'OperationalSyncInProgress' status if you did not compile system tables before (range 2000000004 to 2000000130). No matter what you use Power Shell or Dev Environment.
    Even more, if you compile system objects after you`ve got 'OperationalSyncInProgress' it will not help, so be accurate.
    I spent hours to find this out.
  • abrar273abrar273 Member Posts: 5
    r3c1pd5ea2s1.png

    I am having this issue, when i run Syc Schmea with validation in NAV 2018 Dev Environment it stuck on this screen. no error shown in event viewer as well. and then I compile all table With Sync Schema Now with validation it goes fine for all tables no error found. then I tried Syc Schmea with validation in NAV 2018 Dev Environment but screen stuck with pendin status and no error shown.
    Any suggestion please.
    I want to run data upgrade after this step any suggestion.
    Thanks in advance.
  • RoelofRoelof Member Posts: 362
    Abrar273, I would recommend to cancel the synching and restart the SQL server. Then start the synchronization process using the Dynamics NAV Adminstration Shell (run as administrator), as: sync-navtenant <navservicename>
    Also: make sure that the SQL Server has enough memory to run.
    Roelof de Jong
    http://www.esopro.com
Sign In or Register to comment.