Cannot Control the Account the Mid-Tier Machine is Using

MJVMJV Member Posts: 38
edited 2015-04-28 in NAV Three Tier
NAV 2009 R2 3 Tier Setup.

I have set up NAV with sql server database on NAVDBMachine, MicrosoftDynamicsNavServer on NAVSVCMachine, and the RTC on NAVClientMachine.

I have set up NAVServiceAccount to run everything on NAVDBMachine and NAVSVCMachine.

When I run the RTC on the client, it connects to the NAVSVCMachine using my account, and then the NAVSVCMachine connects to NAVDBMachine using NT AUTHORITY/ANONYMOUS LOGIN.

My SPN for MicrosoftDyanicsNavServer is

setspn -A MicrosoftDyanicsNavServer/NAVSVCMachine.FQDN:7046 MyDomain\NAVServiceAccount

does anyone know why a different account is used to log into the NAVDBMachine than the one I believe I am specifying?

When it logs in as NT AUTHORITY/ANONYMOUS LOGIN, the Domain\User and Password are blank so I get the Invalid User name and Password error.

Thanks so much!
I have done the standard walkthrough at
and I have done the trouble-shooting walk through at
http://blogs.msdn.com/b/nav_developer/a ... -2009.aspx

I can run the RTC on NAVSVCMAchine and it connects properly to NAVDBMachine and it runs correctly.
I can run the RTC on NavClientMachine pointing directly at NAVDBMachine and it runs correctly.
Other processes run under NAVServiceAccount so I know it is a valid account.
NAVServiceAccount is ADMIN on NAVSVCMachine and NAVDBMachine.
NAVServiceAccount is set up with the listener schema and select permission on the sql server db.
I can log into a client machine as NAVServiceAccount and run RTC pointing directly at NAVDBMachine, so I believe the NAVServiceAccount is a valid network account a valid SQL Server Account, and a valid NAV account.
NAVServiceAccount has full control to the server folder on NAVSVCMachine.

Any thoughts on things I can check?

Thanks so much!



  • Options
    shyamkant4ushyamkant4u Member Posts: 3
    Is your SQL Server service is using the same service account that you are using with your NAV Services?
  • Options
    MJVMJV Member Posts: 38
    Thanks so much for your post!

    It turns out I did everything right except I needed a more privileged login to create my SPNs!

Sign In or Register to comment.