NAV Tablet APP on Android/Ipad

DabDab Member Posts: 9
edited 2015-06-08 in NAV Three Tier
Can anyone share details on how they got the 2015 Tablet APP working on an Android or Ipad? We have everything working on tablet via its browser but have not been able to get the APP working that you download from the store. What's the tricks once the tablet browser is working?


  • Options
    JuhaJuha Member Posts: 39
    What is not working? can't you start the app? can't you connect?
    Have you installed your certificate on your tablet? and is it trusted?

  • Options
    DabDab Member Posts: 9
    We can start the app and get the connection screen. We can't connect from the app just the browser on the tablet. The SSL commercial cert is installed on the Android but we still get "Can Not connect to the server message" from the app. We are using the same string that the tablet browser connects with in trying the app. Is that wrong?
  • Options
    defiant701defiant701 Member Posts: 79
    The app has some issues on some Android versions. But you don't need it at all. It also runs in your browser (I would recommend Chrome). Just take the Webclient URL with tablet.aspx instead of default or signin.

    Debuggers don't remove bugs, they only show them in slow-motion

  • Options
    lyngelynge Member Posts: 85

    I'm also seeing this on a server running NAV 2015 Cumulative Update 4.
    The installation has been working earlier (cannot remember which Cumulative Update level).

    I am using a bought commerciel certificate and NavUserPassword login.
    The webclient works as it should and testing the tablet client in a browser by appending /Tablet.aspx to the URL also works.
    I am seeing this on BOTH Android and Apple devices...

    The error is "could not establish connection to server" (freely translated from Danish :-) ) after entering login/password.
    Sometimes the error is returned quite fast - other times the client tries to connect for 10-20 seconds before the error is returned...

    I've tried to debug it - looking in webserver logs etc. without any luck.
    No I simply hope that MS made an error in some Cumulative Updates and the next one will fix it :-)

    If anyone got a suggestion or solution I'm all ears...
  • Options
    lyngelynge Member Posts: 85
    I've now solved this issue on my installation.

    It was caused by me copying the Cumulative Update 4 files manually instead of deinstalling and reinstalling the whole NAV package...
    For NAV 2015 Cumulative Update 4 a new line should be added to the /<NAVInstance>/WebClient/web.config-file.
    Add the line with ...name="StringRessource.axd"... between the existing lines with ...name="ReportViewerWebControl"... and ...name="ClientService.DynamicImageHandler"...:

    <add name="ReportViewerWebControl" verb="*" path="Reserved.ReportViewerWebControl.axd" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=, Culture=neutral, PublicKeyToken=89845dcd8080cc91" resourceType="Unspecified"/>
    <add name="StringResource" verb="GET" path="StringResource.axd" type="Microsoft.Dynamics.Framework.UI.Web.StringResourceHandler, Microsoft.Dynamics.Framework.UI.Web, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35" resourceType="Unspecified"/>
    <add name="ClientService.DynamicImageHandler" verb="GET" path="cs.img" type="Microsoft.Dynamics.Framework.UI.ClientService.ClientServiceHttpHandler`1Microsoft.Dynamics.Framework.UI.Web.DynamicImageHandler, Microsoft.Dynamics.Framework.UI.Web, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35, Microsoft.Dynamics.Framework.UI.ClientService" resourceType="Unspecified"/>

    Thanks to Michael at Microsoft for giving me this solution.
    Hopefully I've now shared it so others can solve it as well :-)
  • Options
    NicolaiHNicolaiH Member Posts: 23
    Thank you very much, that missing line in the web.config fixed my problem too :D

    I was testing the app on Windows 10, iPad and my Surface tablet same problem on all devices. Most times I would get an error message about not being able to connect, other times there was just a blue background an nothing happened. On Windows 10 the app went crazy and used 5,6 GB RAM before my pc froze for a couple of minutes and I was able to kill it in task manager.

  • Options
    TJ-JMA-DKTJ-JMA-DK Member Posts: 2
    Using CU5 the missing lines in the web.config file has been added - but I still got the same problem.
    Trusted public certificate are used, the connection Works fine in a browser, but the app won't Work.

    Many others have the same problem - but cann't find a solution.

Sign In or Register to comment.