Options

XMLPort import mixes records

damkjerdamkjer Member Posts: 12
edited 2014-07-02 in NAV Three Tier
Hi.

I've got a text file that I need to import. It's semicolon separated without field delimiter.

I've set field delimiter to <NONE> and field separator to ;.

When I import the file it mixes data from records.

Example:

File contains 15 fields

00000;Txt01;Txt02;Txt03;Txt04;Txt05;Num01;Num02;Num03;Num04;Num05;Num06;Num07;Num08,Txt06
11111;Txt11;Txt12;Txt13;Txt14;Txt15;Num11;Num12;Num13;Num14;Num15;Num16;Num17;Num18,Txt16
22222;Txt21;Txt22;Txt23;Txt24;Txt25;Num21;Num22;Num23;Num24;Num25;Num26;Num27;Num28,Txt26
etc.

Now - when I import them into text variables in a XMLPort and output the result via MESSAGE I get the following result (only fields 1,2 and 3:

00000 <empty> <empty>
11111 Txt01 Txt02
22222 Txt11 Txt12

Or to put it in words: it connects the first field in the file with the remaining fields of the prevoius record. Thus the first record has no value in anyother field than the first.

To add to the confusion: It skips record no. 5 in the file - every time I've tried.

I tried to change the file so that fields are surrounded by " " and changed the XMLport fielddelimiter accordingly. No luck - still the same.

Am I messing something up or is the program (NAV 2013 R2, latest version) messed up? :?

Comments

  • Options
    damkjerdamkjer Member Posts: 12
    Please forget - my bad (must have left my functional brain at home today).

    So after spending all morning it was solved in 15 minutes!!
Sign In or Register to comment.