Options

Upgrade to NAV2013R2 table import compile errors

phifiphifi Member Posts: 4
edited 2014-06-16 in NAV Three Tier
Hello,
i am doing an Upgrade to NAV 2013 R2 and having some troubles on Step 11.b of the msdn blog upgrade guide http://blogs.msdn.com/b/nav/archive/2013/11/22/upgrade-toolkit-for-upgrading-data-from-microsoft-dynamics-nav-2009-r2-and-microsoft-dynamics-nav-2009-sp1-to-microsoft-dynamics-nav-2013-r2.aspx

Currently i want to import the customized 2013 R2 Table objects in 2013 R2 Development Environment and get compile errors on a whole lot of tables.

For Example if i want to import Table 6 Customer Price Group it cancels the import with the compile error that there is no Field "VAT Bus. Posting Gr. (Price)".
In fact, "VAT Bus. Posting Gr. (Price)" is missing on Table 311, Sales & Receivables Setup which Table 6 refers to in it's the source code.
I had to import Table 311 first. After that, import of Table 6 worked fine.

Did i do something wrong in the upgrade process to get these problems?
Is there a general solution for this other than build a cronus 2013 R2 with customized table objects, delete code, import table objects without code and afterwards import the "real" table objects with code?

As a colleague of mine didn't get this kind of errors on his last 2013 R2 upgrade on an older Client version, could this possibly be a bug in 7.10.36703?

Thanks for your help in advance...

Comments

  • Options
    prateekarya2011prateekarya2011 Member Posts: 40
    Did you ever tried compare objects? actually once i performed a partial upgrade, in that case i had used this compare tool.
    Steps ->
    Take Modified objects (Table) out from source Db
    Compare the Table of Source Db & destination Db
    Move the changes to Destination Db
    Save the new file & then compile the imported objects.
    ("Compare it" is the tool that i used you can give it a try.)
  • Options
    phifiphifi Member Posts: 4
    @prateekarya
    Yes, i've tried this to with no success.

    Now, after hours of trial and error i finally downgraded the navision installation to cumulative upgrade 6 and it works again.
    Seems like ce CU7 is simply crap and i would not recommend to use this upgrade. Besides the mentioned issue, i also had some minor ones with this version.

    To me, it looks like Microsoft "outsourced" the testing to the partners and customers :thumbsdown:
  • Options
    saravanans87saravanans87 Member Posts: 36
    Is you database having ISV or Add-On?
    Software Developer,
    Archerpoint India Pvt. Ltd,Chennai.
  • Options
    phifiphifi Member Posts: 4
    I guess not, as i don't know what "ISV or Add-on" is :)
    Is it some kind of tool?
  • Options
    KowaKowa Member Posts: 918
    phifi wrote:
    I guess not, as i don't know what "ISV or Add-on" is :)
    ISV
    http://en.wikipedia.org/wiki/Independen ... are_vendor
    Some examples for add-ons
    http://pinpoint.microsoft.com/en-US/app ... V&fcrc=USA
    Kai Kowalewski
  • Options
    Miklos_HollenderMiklos_Hollender Member Posts: 1,598
    I may be struggling with a similar problem... is it like update 7 compiling imported objects one by one before importing all of them so if they reference each other (a field, a function in another object) then we have problems?

    As I get weird error messages importing an add-on.

    Not sure if I should go back to update 6 esp. that I already have update 7 objects merged in. Maybe I should just try to replace the development environment from update 6...
  • Options
    Miklos_HollenderMiklos_Hollender Member Posts: 1,598
    Hey, I found something. It is actually possible to import uncompilable objects to R2 U7. I tested it so: make a new table, put a report on it, export the report, delete the table, delete the report, import the report. It worked, the object was there, just not executable and not compilable, as expected.

    I am suspecting that my problem is actually trying to install an R1 add-on onto an R2 system. R1 objects get automatically recompiled, and partially I don't have the right to do that with the add-on (I guess) and partially because they are fully compatible and are not compilable, thus rejected.

    Was it your problem as well? How did U6 help you? U6 doesn't want to remcompile R1 objects?
  • Options
    Miklos_HollenderMiklos_Hollender Member Posts: 1,598
    So does anyone know how does Update 7 differ from Update 6 in this regard?
Sign In or Register to comment.