Options

NAV 2009 R2 Test Database

mmullanmmullan Member Posts: 2
Hello, I recently took a full backup of our Live database and created a new training database to load some test objects in. My users are getting various permissions errors, one common one is "You do not have permission to read the Object table", not sure as to why due to the fact the permissions were copied over from the Live database and I have done this successfully in the past with other test databases. I have synchronized all logins to no avail. Stange thing, my windows account, not the SA can access the test database with no issue I know I have elevated priviledges obviously, but I even made a few of the users Super and they still could not open the company file. Any help is greatly appreciated!

Comments

  • Options
    vremeni4vremeni4 Member Posts: 323
    Hi,

    To simplify the things NAV has two "doors" before you can get in.
    The first door is the login on the SQL server. (This is different then SQl Database user)
    In other words the user has to have a login on the SQL Server.
    The second door, is the User table in Navision.
    When you insert user in Navision it automatically creates a Login on the SQL Server.
    Hence users are not aware that there is another "door".

    When you take a backup from one SQL Server and you restore it on another, only database users are copied.
    The SQL logins are not copied.
    For Example:
    a Login for user XYZ exist on the LIVE SQL Server and in NAV, but it does not exist on the Test SQL Server.
    When you restore the backup from LIVE on the TEST SQL Server the XYZ won't be able to login as SQL login is missing. (Anyhow SQL Database user and NAV user are there)
    Two options to resolve the issue:
    1. You start SQL Studio manager and run a script to fix "Orphan users" in SQL or yo create the login on the SQL Server for that user. Result is the same.
    2. You delete the user form NAV, and create a user again. (This does not work all the time depends on the security settings. )

    I hope this helps.

    Thanks.
Sign In or Register to comment.