NAV 2013 R2 two services with different builds on same PC

nuno.silvanuno.silva Member Posts: 29
edited 2014-04-24 in NAV Three Tier
Anyone have problems running different builds of NAV 2013 R2 on same server?
I create a new service with build 7.1.35473.0 and I started the service a I was able to login with RTC and everything worked. After that I overwrite the files with the new ones from build 7.1.36366.0 on the Service folder and RTC folder, open the database with development environment and convert the database. After that I try to start the service but it won’t start gives a timeout and if I look on event viewer I always have two errors:
The first one
Application: Microsoft.Dynamics.Nav.Server.exe
Framework Version: v4.0.30319
Description: The application requested process termination through System.Environment.FailFast(string message).
Message: The service could not write to the EventLog because of: 'The source was not found, but some or all event logs could not be searched. To create the source, you need permission to read all event logs to make sure that the new source name is unique. Inaccessible logs: Security.'.
The original message is: 'Server instance: SLB_DEV_36366
"MicrosoftDynamicsNavServer$SLB_DEV_36366 is using the configuration file: C:\Program Files\Microsoft Dynamics NAV\71\Service SLB\SLB_DEV_36366\Microsoft.Dynamics.Nav.Server.exe.config"'
at System.Environment.FailFast(System.String)
at Microsoft.Dynamics.Nav.Types.EventLogEntryWriterProxy.WriteEntry()
at Microsoft.Dynamics.Nav.Types.EventLogWriter.ProcessEventQueue()
at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)
at System.Threading.ThreadHelper.ThreadStart()

the second one
Faulting application name: Microsoft.Dynamics.Nav.Server.exe, version: 7.1.36366.0, time stamp: 0x533b28f3
Faulting module name: unknown, version:, time stamp: 0x00000000
Exception code: 0x80131623
Fault offset: 0x00007ffbfcd92bd8
Faulting process id: 0x201c
Faulting application start time: 0x01cf5ed53ae0afc8
Faulting application path: C:\Program Files\Microsoft Dynamics NAV\71\Service SLB\SLB_DEV_36366\Microsoft.Dynamics.Nav.Server.exe
Faulting module path: unknown
Report Id: 78c248d6-cac8-11e3-bee5-e8113245398f
Faulting package full name:
Faulting package-relative application ID:

Don’t have any clue about them, anyone can help? Thanks.
Nuno Silva


  • Options
    Sam_MorrisSam_Morris Member Posts: 32
    I had the exact same error as you this morning. I was trying to setup an Azure server to host development databases for all our customers on NAV 2013 R2. This means that I also needed to run more than one build. After lots of messing around I managed to solve it by changing the login account for the NST service. Instead of using NETWORK SERVICE, I used a local machine admin account (also making this account dbowner for the databases). It's a bit strange because NETWORK SERVICE worked fine with the demo database that was installed by default.
  • Options
    nuno.silvanuno.silva Member Posts: 29
    I confirm Sam solution, I changed the NST service login to a local admin and everything start working and the NST service with build 7.1.35473.0 is still working with the NETWORK SERVICE.

    Thanks Sam
    Nuno Silva
  • Options
    vremeni4vremeni4 Member Posts: 323

    After some investigation I realized that the problem is caused by the fact that NETWORK SERVICE does not have access on the folders and files for NST.
    If you right click on the folder
    C:\Program Files\Microsoft Dynamics NAV\80\Service
    and then select Properties -> Security tab
    In a new window the NETWORK SERVICE has to have full access on this folder and all sub-folders.

    The next step is to either
    - uninstall the service and to install it again, this would resolve the issue
    or much simpler,
    - you change the user for NAV Service to "Local System" start and stop the service, then change it back to NETWORK SERVICE

    I hope this helps.

Sign In or Register to comment.