Options

COM problem within 2013 R2

SelaviSelavi Member Posts: 4
edited 2014-03-18 in NAV Three Tier
Hello everyone.

I have questions to whom who has allready been into 2013 R2.

problem could be trivial but here it is.

I have been provided with dll (tlb) file from device manufacturer. succesefuly installed it and ran up till version 2009 clasic. Dll is with events.

now on 2013 after importing needed fobs compiler compiles it without error, but when actually running it could and calling methods Navision says that call to mydll.config failed with this message mydll.config could not be found.

the strange thing is that i do not see automation server in custom controls nor i can choose it from net assambley. however i can see control in 2009.

anybody faced this kind of issue before?

Comments

  • Options
    geordiegeordie Member Posts: 655
    Are you able to see in NAV 2013 R2 the record for the dll mentioned in Control Add-in table?
  • Options
    SelaviSelavi Member Posts: 4
    geordie wrote:
    Are you able to see in NAV 2013 R2 the record for the dll mentioned in Control Add-in table?

    No i am not. it's not visibile in Control Add-in Table (2000000069).
  • Options
    Marije_BrummelMarije_Brummel Member, Moderators Design Patterns Posts: 4,262
    Automation variables only run on the client.
  • Options
    SelaviSelavi Member Posts: 4
    Automation variables only run on the client.

    that's right.
    when call function create. it's with parameters (true,True);
    it kinda works, but not all methods is seen, it returns message i stated above.

    yes in this case all three tiers are on one PC
Sign In or Register to comment.