Options

NAV2013 could not locate add-in library in rollup11 (b36076)

erwin-mibusoerwin-mibuso Member Posts: 8
edited 2014-03-21 in NAV Three Tier
We updated from NAV2013 rollup 5 (build 35201) to NAV2013 rollup 11 (build 36076) by following procedure:
+ replacing service tier folder manually
+ replacing RTC folder manually

The client addin table is filled correct (refilled it again manually to make sure the values are ok).
Unfortunately i still get this error; although it worked fine on rollup 5.
The other functionality works fine and the RTC shows the new build version.

We are experiencing the same issue with another addin, so my guess is none of the addins are loaded/working.

Does anyone have any ideas what could be the cause of this?

Comments

  • Options
    vremeni4vremeni4 Member Posts: 323
    Hi,

    I had similar issue, but it was not related to the rollup.
    I copied the add-ins files from the folder
    C:\Program Files (x86)\Microsoft Dynamics NAV\70\RoleTailored Client\Add-ins\BusinessChart
    into the folder
    C:\Program Files (x86)\Microsoft Dynamics NAV\70\RoleTailored Client\Add-ins\
    and restarted the NAV Server and it worked.

    Try it, if it works great if it does ....
  • Options
    grossgross Member Posts: 4
    Hi -

    I've got this same error with SMTP after the rollup11 was applied. It worked fine prior to the rollup though.

    Any other thoughts on how to resolve this issue?

    Thanks,

    Greg
  • Options
    grossgross Member Posts: 4
    ](*,)

    This has been resolved - windows server security issue. I initially copied the rollup files from a network location, so they became blocked. I re-downloaded the hotfix to the servers in question and re-applied the patch. All my Add-ins suddenly came back to life.

    Greg
  • Options
    mdPartnerNLmdPartnerNL Member Posts: 802
    gross wrote:
    ](*,)

    This has been resolved - windows server security issue. I initially copied the rollup files from a network location, so they became blocked. I re-downloaded the hotfix to the servers in question and re-applied the patch. All my Add-ins suddenly came back to life.

    Greg

    Had this problem too. It's ok the block these kind of files but would like to have a clear error that is it is blocked and not an error from somewhere else ..
  • Options
    erwin-mibusoerwin-mibuso Member Posts: 8
    Thanks for the reply all.

    I've read your post saying it is a "windows server security issue", could you be any more specific about what to do to solve this?

    Thanks in advance :thumbsup:
  • Options
    erwin-mibusoerwin-mibuso Member Posts: 8
    Update: I have redownloaded the rollup from the website and extracted it on the server itself.
    As written above, this also fixed my issue with this.

    Problem solved, thanks all!
Sign In or Register to comment.