Options

Web Service Problem

tularamtularam Member Posts: 97
edited 2014-02-23 in NAV Three Tier
I have searched many times and
I am working on Dynamics NAV 2009 SP1 RTC. I have installed everything on same server. My Server have 3 ips: 192.168.1.20, 127.0.0.1 and one Public IP 82.XX.XX.XX.
I recently published web service. I can access the web service within the box using
[server-Name]:7047/DynamicsNAV/WS/NAV_Company_Name/services.
127.0.0.1:7047/DynamicsNAV/WS/NAV-Company_Name/Services.
192.168.1.20:7047/DynamicsNAV/WS/NAV_Company_Name/Services.

How can I access it from outer world??
I even can not open it in the same server using public IP like
[Public IP]:7047/DynamicsNAV/WS/NAV_Company_Name/services

Answers

  • Options
    JuhlJuhl Member Posts: 724
    First of all you have to configure your firewall to forward port 7047 to you internal ip.
    Regarding using your external ip internally, depends on your firewall configuration, and if it support NAT loopback, otherwise use the internal ip internally and your global ip externally.
    Follow me on my blog juhl.blog
  • Options
    tularamtularam Member Posts: 97
    Yes. I allowed port 7047, but no luck. I even tried disabling Firewall but can not connect..
  • Options
    JuhlJuhl Member Posts: 724
    Remember that you have 2 firewalls. The one in you internet connection firewall/router, and the one in you OS.
    The one in the OS you can disable, or configure.
    But the other you cant. This you must configure for allowing the connection through NAT.

    Somme firewalls require you to configure NAT and firewall seperatly.

    Try setting up Remote Desktop on port 3389 and get that working first from the outside.
    Then you have you configuration for 7047, and you have eliminated NAV from the firewall setup.

    If you can get Remote Desktop working, then it is NAV related.

    Good luck.
    Follow me on my blog juhl.blog
  • Options
    tularamtularam Member Posts: 97
    Thank You Juhl,
    I found that My router has no port forwarding for port 7046 & 7047. May be this is the issue. I will confirm it if it works fine.

    Thank You
  • Options
    JuhlJuhl Member Posts: 724
    Your welcome :-)
    Follow me on my blog juhl.blog
Sign In or Register to comment.