Options

Windows 8 can break formatting of RDLC reports

brunellibrunelli Member Posts: 9
edited 2014-02-17 in NAV Three Tier
For a better understanding of the following, I have to explain that I am located in Switzerland, using regional settings de-CH (fr-CH, it-CH). It might be that this problem is just a local issue.

Last week I faced the following problem. When I ran NAV 2013 R2 pages and reports under Windows 8, all decimal values where not shown as expected:
- Windows 7 (expected): 123’456’789.00
- Windows 8: 123 456 789,00

I thought "not a problem" and checked region and language settings. As expected, it was not set properly and I changed decimal symbol and digit grouping symbol to the desired values. This solved the problem for pages, but it did not work for reports. A long journey started: Restart client, restart NST, restart server, copy settings to system accounts, checking if language setting is “=User!Language” in the layout, restart again, and so on. Still no solution.

I came to the following conclusion:
- MS changed the default settings of de-CH (and others) from 123’456’789.00 (Windows 7 and earlier) to 123 456 789,00 (Windows 8). May be other settings changed too, but I did not investigate further. It is not clear why this changed. but users here do still expect to have decimals displayed the old (fashion) way.
- NAV Windows Client is using the formatting based on user settings.
- The reporting engine (with property Language=User!Language) takes the locale (de-CH in my case) from the user settings. But the detail settings for formatting are taken from the OS default.

Two solutions came to my mind. First: Changing all the reports in NAV. This is not really an option. Second: Changing the OS default settings of de-CH.

After a long session with Mr. Registry and Dr. Google (sorry Mr. Bing), I found the following about “Custom Locales” http://msdn.microsoft.com/en-us/library ... 85(v=vs.85).aspx. I did choose the way “Replacement locale” and with the help of Locale Builder 2.0 (http://www.microsoft.com/en-us/download ... x?id=41158) I managed to build an .msi package that overwrites the OS default settings of de-CH. The process is quite straight forward and worked without glitches.

Right now, this solved my problem. But hey, I just tested it for a few days now. May be this will cause additional problems in the future at completley other ends. A second tradeoff of this solutions is, that I have to debate with system administrators (in my company and at customers) to explain why they need this to have NAV running the way I want. I expect some mistrust here and then.

My question: Did anybody else face this problem too? How did you come around the issue?

P.S. My second post in this forum. Thanks to administrators and users for keeping up this (best) resource for NAV knowledge. Mibuso.com saved my day many times.

Comments

  • Options
    clauslclausl Member Posts: 455
    This is a bug in Windows 8 and Server 2012, if possible change regional settings to German, then your reports should work.

    I believe other people have reported this to Microsoft, but maybe to be sure, you should also report this.

    /Claus Lundstrøm
    Claus Lundstrøm | MVP | Senior Product Manager | Continia.com
    I'm blogging here:http://mibuso.com/blogs/clausl and used to blog here: http://blogs.msdn.com/nav
    I'm also offering RDLC Report Training, ping me if you are interested. Thanks to the 700 NAV developers that have now already been at my training. You know you can always call if you have any RDLC report issues :-)
  • Options
    brunellibrunelli Member Posts: 9
    Thank you for your response Claus. Microsoft is aware of the problem. It is not jet clear when or if the bug will be fixed. Changing the regional settings to German does not fix the problem. de-DE is representing decimals the following: 123.456.789,00.
Sign In or Register to comment.