CaptionClass not working in RTC

ashcoatesashcoates Member Posts: 3
edited 2013-12-12 in NAV Three Tier

We have added a number of fields to the Item Page that uses CaptionClass functionality to dynamically set the Field Caption. We have used the standard way to do this via the CapationClassTranslate function in codeunit 1 and populating the CaptionClass property on each of the fields.

This has always worked fine pre-RTC and even works correctly when running the Page from the Development Environment, but when run from the Role Centre or when run via the Item List or via a lookup the captions don't display.

The standard Dimension Captionclass functionality works correctly too.

Any help would be very appreciated.


  • Options
    geordiegeordie Member Posts: 655
    What about using '1,5,,' + MyGetCaption syntax as CaptionClass, defining a function providing the caption instead of modifying codeunit 1?
    Works fine in 2013 too...can be a suitable solution in your case?
  • Options
    ashcoatesashcoates Member Posts: 3
    Thanks for your reply, that does work but again only when running the Item Card directly, when calling it from the List Page it doesn't display??

    I've tried adding the Captionclass call in both the page and the table and added currpage.UPDATE(FALSE) to the onaftergetrecord.

    The problem seems to be when the record is already in memory so the call to the server doesn't have to happen again.

    Very confusing!
Sign In or Register to comment.