Options

Regional settings Windows 8

MattieMattie Member Posts: 3
Hello,

I'm wondering if somebody has already noticed this...

NAV 2009 R2 installed on a windows 8 machine. NAV is not detecting the regional settings well.
For example when setting the grouping to nothing (123456), Navision is taking a " " (123 456).
When exporting a table to excel, excel will threat this as text and not as number.

Is there a solution for this?

Thanks!

Comments

  • Options
    vaprogvaprog Member Posts: 1,125
    Hello Mattie,
    Mattie wrote:
    setting the grouping to nothing (123456)
    This is about the thousands separator, right?
    Mattie wrote:
    Navision is taking a " " (123 456).
    Accepting the blank on input and preserving it? on what type of field/variable? Integer? Code? In the latter case, does NAV treat it as text or as a number?
    Mattie wrote:
    When exporting a table to excel,
    Using a data port, or Excel Buffer table, or using a Send-to App from the toolbar?
    Mattie wrote:
    excel will threat this as text and not as number.
    Isn't that what is to be expected, because your Windows is configured that way?
    Mattie wrote:
    Is there a solution for this?
    So, what's wrong and how should it be different?
    Mattie wrote:
    Thanks!
    Thanks for being more specific when asking for help.
  • Options
    MattieMattie Member Posts: 3
    Indeed, it has something to do with the regional settings on the computer.
    Normally Navision is threating numbers as setup in the regional settings, but this isn't...

    So when you put 123456 in a numeric field, it is shown as 123 456. According to the regional settings, but on windows 8 this is not...

    When I copy a bunch of data from nav to the clipboard and paste in excel numers below 1000 are treathed like numbers. Numbers above 999 are threated like text because of the " " between thousands and hundereds...
Sign In or Register to comment.