Options

NAV 2013 3-tier Installation Problems

matthiasrinsermatthiasrinser Member Posts: 2
edited 2014-01-29 in NAV Three Tier
Hello,

I am trying to install Dynamics NAV 2013 on 3 Hyper-V computers (3-tier):

NAVSQL : Windows Server 2012 x64 : SQL Server 2012 Express (Cronus DB)
NAVSERV : Windows Server 2012 x64 : AD + DC + DNS + NAV Server
NAVCLIENT : Windows 8 x64 : NAV RTC + Development Client

Firwalls are all disabled and I can ping each computer.
All 3 computers are in the domain "DEMONAV.local" and everything has been installed with the User "DEMONAV\Administrator".

I created an new Domain-User "NAVSQLService" which is a Domain-Administrator.
The sql service and the NAV service are running with this user.
The configuration of NAV is standard (windows login, all ports are standard).
Here are the registered SPNs for the user "DEMONAV\NAVSQLService":
DynamicsNAV/NAVSERV
DynamicsNAV/NAVSERV:7045
DynamicsNAV/NAVSERV:7046
DynamicsNAV/NAVSERV:7047
DynamicsNAV/NAVSERV:7048
DynamicsNAV/NAVSERV.DEMONAV.local
DynamicsNAV/NAVSERV.DEMONAV.local:7045
DynamicsNAV/NAVSERV.DEMONAV.local:7046
DynamicsNAV/NAVSERV.DEMONAV.local:7047
DynamicsNAV/NAVSERV.DEMONAV.local:7048
http/NAVSERV:7047
http/NAVSERV:7048
http/NAVSERV.DEMONAV.local:7047
http/NAVSERV.DEMONAV.local:7048
MSSQLSvc/NAVSQL
MSSQLSvc/NAVSQL.DEMONAV.local

The users DEMONAV\SQLNAVService and DEMONAV\Administrator both have full rights on the SQL-Server and the CRONUS-Database (public + db_owner).

I can access the database with the SQL Server Management Studio 12 Express and Windows-Login (DEMONAV\Administrator).
Also I can access the database and the CRONUS company with the NAV Development Client from the server "NAVCLIENT".
When I try to open the RTC Client (on "NAVCLIENT") then the NAV service tier crashes and the RTC Client tells me, that the connection was lost (during the RTC Loading-Screen).
In the event-log on "NAVSERV" is a new error entry with following Informations:

Server instance: DynamicsNAV70
Session type: RoleTailoredClient
Session ID: 1
User: DEMONAV\Administrator
Type: System.Runtime.InteropServices.ExternalException
ErrorCode: -2147467259
Message: A generic error occured in GDI+.
StrackTrace:
at System.Drawing.Image.Save(Stream stream, ImageCodeInfo encoder, EncoderParamerters encoderParams)
...

The BPA for NAV 2013 always says 1 error and 1 warnung, that a SPN is missing. The missing SPN is registered in the list above.

What can I do to solve the problem?

Comments

  • Options
    Peter76Peter76 Member Posts: 10
    I haven't seen this error yet, so I am also in the dark a bit, but just wanted to give you some input.

    Did you try the latest build of NAV 2013? Are you getting the same error when you try to open NAV's Windows client on the NST server?

    The error indicates that NAV internally tries to save an image in a stream and that error is usually related to permission issues. So what it could be is that you don't have the permissions to the NAV temp directory or one of the SPNs is really not correct. Usually, if the BPA complains, there is really something wrong.
    Peter Zentner
    NAV Practice Manager at Clients First Business Solutions

    Did you check out our free training videos at www.dynamics-nav-training.com?
    Look at our blogs.
  • Options
    JaspisJaspis Member Posts: 4
    Hi Matthias,

    have you ever found a solution to your issue?

    Regards.
    Jaspis
  • Options
    rdebathrdebath Member Posts: 383
    In this case I would try putting a service tier directly on the SQL server machine.
    Four main reasons
    • SQLEXPRESS is usually configured to have network access disabled.
    • The domain controller doesn't have any such thing as a local administrator; it DC admin or nothing.
    • Many things react slightly differently on the DC and frequently Microsoft hasn't done full testing in this setup. (They just say 'not recommended') .
    • The load patterns of the Service tier and SQL mostly complement each other as long as you make sure they have enough RAM (or manage it).

    If you're testing the network setup I'd suggest you create a fourth VM for the service tier to make it a more realistic environment. (And make sure network access is turned on for SQLEXPRESS)

    BTW: I have had no problems with SPNs with 2013, the combination of the service tier no longer using impersonation and it being able to create the SPNs it needs itself seems to have solved the problems for me.
Sign In or Register to comment.