Options

Error While Import Data thru Rapidstart service

st0328st0328 Member Posts: 97
edited 2013-12-16 in NAV Three Tier
Hi,

I am trying to import 5 records in to T81 through Configuration Packages.

The Fields i selected were:

1. Journal Template Name
2. Line No.
3. Account Type
4. Account No.
5. Posting Date
6. Document No.
7. Bal. Account No.
8. Amount
9. Bal. Account Type

But, while importing an error was coming like

Microsoft Dynamics NAV


The Config. Package Data does not exist. Identification fields and values: Package Code='TABLE 81',Table ID='81',No.='1',Field ID='480'
OK


please suggest me

Comments

  • Options
    golfergolfer Member Posts: 88
    It seems you have a Config Package Card called TABLE 81 but you have not defined the table 81 in this package. The packages can contain as many tables you want, so you can call the package card TESTING or whatever you want, then add the tables you want to work with. In this particular case you would need to add table 81 and then press Table-Fields and define the fields you have in the file you want to import.

    Hope this helps.
  • Options
    st0328st0328 Member Posts: 97
    golfer wrote:
    It seems you have a Config Package Card called TABLE 81 but you have not defined the table 81 in this package.

    I defined the table in the Configuration package Subpage, My table is 81. with that i selected the fields like i mentioned in the above post and exported to excel and Added new data in that.

    Now i am trying to import the file at that time error coming.
  • Options
    golfergolfer Member Posts: 88
    Looking closer at the error message, it indicates No. 1 and Field 480, which is the field Dimension Set in table 81. So it seems something is wrong with that field or its content in the file.
  • Options
    MbadMbad Member Posts: 344
    Got the exact same error.

    It is programmed so if you have a field with number 480 in the table, it will always require that field in the import - even if you dont include the field in the package definition and you dont use dimensions as columns.
  • Options
    lethanhlethanh Member Posts: 6
    I think you should:

    1. Add "Journal Batch Name" field as it is part of table 81 primary key.
    2. Remove all fields, except your fields (9+1) in Config. Package Fields.
    3. Make sure your excel file was exported from package "TABLE 81" due to Excel XML mapping and Schema Validation.
    4. Make sure import back using package "TABLE 81".
    5. Make sure tables of package "TABLE 81" are all mapped with Worksheets of Excel.

    There is a nice and powerful wizard tool. It can help you speed up import/export data from/to Excel via Data Migration. You can search it on youtube, may be "navision 2013 excel import export", I don't remember the name exactly.

    Hope this can help you!

    Best Regards,
    Le Thanh.
  • Options
    swadminswadmin Member Posts: 1
    I can confirm that simply including field 480 "Dimension Set ID" in the configuration package and then leaving the field blank in my import data solved this problem for me.
Sign In or Register to comment.