NAV 2013 Upgrade from NAV 2009 - Login failed for user error

ichladilichladil Member Posts: 68
edited 2013-03-21 in NAV Three Tier

we are upgrading NAV 2009 R2 database to NAV 2013 (UK versions). In the step which converts the database from NAV 2009 to NAV 2013, where we open the "old" database with NAV 2013 DEV environment for the first time it fails after some data conversions with the following message:
Microsoft Dynamics NAV Development Environment
The following SQL Server error or errors occurred:
18456,"28000",[Microsoft][SQL Server Native Client 10.0][SQL Server]Login failed for user 'xxxCLOUDxxx\Administrator'.
4060,"42000",[Microsoft][SQL Server Native Client 10.0][SQL Server]Cannot open database "xxx" requested by the login. The login failed.

The login mentioned in there exists in the SQL server and it is actually sysadmin. It is the login we run the conversion with. The database itself is close to the standard NAV 2009 database with some minor modifications.

Has anybody encountered such an error? What may be causing it?

Thanks ahead for your advice,


  • Options
    postsauravpostsaurav Member Posts: 708

    Cause of Issue -

    Before opening the database you don't have any windows login in the database.

    Resolution -

    First - Delete content of below listed tables from SQL -
    1) dbo.User
    2) dbo.User Metadata
    3) dbo.User Personalization

    For same right click the tables from the database and select EDIT Top 200 Rows and delete all contents.

    Second -
    Follow the steps as provided in http://saurav-nav.blogspot.in/2013/02/error-after-restore-sql-backup-of-nav.html
    While adding roles for the Network user add rights of db_datareader, db_Datawriter & db_ddladmin.

    The title is different but applies to your problem also.

    Hope this resolves your issue.

    Thanks & Regards,
    Saurav Dhyani

    Do you Know this About NAV?

    Connect - Twitter | Facebook | Google + | YouTube

    Follow - Blog | Facebook Page | Google + Page
  • Options
    ichladilichladil Member Posts: 68
    I have finally sorted this one out. It seems that the error message just indicates that NAV tries to use different SQL connection while in Single User mode in database when the failure occurs. I.e. it says actually nothing about the real problem.

    The real problem was:
    • Issue 1 - Linked tables. There were some tables that were originally linked, then in dev. environment changed to not linked. It seems that conversion did not handle these however correctly.
    • It was also failing for "unknown" reason on No. Series Line table. I have replaced it by Vanilla object and it helped.

    Important thing is that if I have used SQL Profiler I have seen that conversion creates temp table per each converted table. Populates it with data, processes it and in the end deletes something. In my occurrences it has never reached the finalizing statements per table. Also when I have watched the progress bars in conversion the culprit was the last table displayed there. Mainly due to the rollback it has been left in place longer so I had the option to at least read the table name.

    I hope this info will help somebody.

  • Options
    Lars_WestmanLars_Westman Member Posts: 116
    Old thread but worth an update.

    Thank's for the Profiler tip! By using Profiler I was also able to see which table that was causing problems (but it's actually also possible to see in the progress bar during the conversion). It had nothing to do with linked tables for me. The conversion just stopped at a perfectly normal custom table. After conversion I could import the table from a fob without any problems...

    I really tried to go to the bottom with the problems. I tried renaming the table, changing field length (it has a Code(1) in it), deleting statistics, deleting data etc. etc, but nothing except deleting the table helped. Really strange....

    I'll be moving the data manually to that table after delete table, convert database and import table.

Sign In or Register to comment.